Closed Bug 1784303 Opened 2 months ago Closed 2 months ago

Intermittent TinderboxPrint: Per-test run of .../dom/base/crashtests/1700237.html<br/>: FAILURE

Categories

(Core :: DOM: Core & HTML, defect)

defect

Tracking

()

RESOLVED FIXED
105 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox-esr102 --- unaffected
firefox103 --- unaffected
firefox104 --- unaffected
firefox105 --- fixed

People

(Reporter: ctuns, Assigned: jjaschke)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Push with failures: https://treeherder.mozilla.org/jobs?repo=autoland&group_state=expanded&selectedTaskRun=JMjftMqhRi2NwCHZbrREQw.0&revision=e65ed6790ab3eabc863eba423f3ceb98d31b167f&searchStr=os%2Cx%2C10.15%2Cwebrender%2Copt%2Ctest-macosx1015-64-qr%2Fopt-test-verify%2Ctv
Failure log: https://firefox-ci-tc.services.mozilla.com/tasks/JMjftMqhRi2NwCHZbrREQw/runs/0/logs/public/logs/live.log

[task 2022-08-11T15:38:24.298Z] 15:38:24    ERROR - Return code: 5
[task 2022-08-11T15:38:24.304Z] 15:38:24    ERROR - Got 1 unexpected statuses
[task 2022-08-11T15:38:24.304Z] 15:38:24    ERROR - Got 3 unexpected crashes
[task 2022-08-11T15:38:24.305Z] 15:38:24     INFO - TinderboxPrint: reftest-crashtest<br/>63/<em class="testfail">1</em>/0&nbsp;<em class="testfail">CRASH</em>
[task 2022-08-11T15:38:24.307Z] 15:38:24    ERROR - # TBPL FAILURE #
[task 2022-08-11T15:38:24.307Z] 15:38:24  WARNING - setting return code to 2
[task 2022-08-11T15:38:24.308Z] 15:38:24    ERROR - TinderboxPrint: Per-test run of .../dom/base/crashtests/1700237.html<br/>: FAILURE
[task 2022-08-11T15:38:24.309Z] 15:38:24     INFO - Per-test suites: {}
[task 2022-08-11T15:38:24.311Z] 15:38:24     INFO - Running post-action listener: _package_coverage_data
[task 2022-08-11T15:38:24.312Z] 15:38:24     INFO - Running post-action listener: _resource_record_post_action
[task 2022-08-11T15:38:24.312Z] 15:38:24     INFO - Running post-action listener: process_java_coverage_data
[task 2022-08-11T15:38:24.312Z] 15:38:24     INFO - [mozharness: 2022-08-11 15:38:24.312533Z] Finished run-tests step (success)
[task 2022-08-11T15:38:24.312Z] 15:38:24     INFO - Running post-run listener: _resource_record_post_run
[task 2022-08-11T15:38:24.830Z] 15:38:24     INFO - instance_metadata.json not found; unable to determine instance type
[task 2022-08-11T15:38:24.852Z] 15:38:24     INFO - Validating Perfherder data against /opt/worker/tasks/task_166022717716216/mozharness/external_tools/performance-artifact-schema.json
[task 2022-08-11T15:38:24.855Z] 15:38:24     INFO - PERFHERDER_DATA: {"framework": {"name": "job_resource_usage"}, "suites": [{"name": ".overall", "extraOptions": ["e10s", "buildbot-unknown"], "subtests": [{"name": "cpu_percent", "value": 13.63476871468926}, {"name": "io_write_bytes", "value": 43862364160}, {"name": "io.read_bytes", "value": 33064935424}, {"name": "io_write_time", "value": 1685129}, {"name": "io_read_time", "value": 865911}]}, {"name": ".start-pulseaudio", "subtests": [{"name": "time", "value": 0.00045180320739746094}]}, {"name": ".install", "subtests": [{"name": "time", "value": 19.548603773117065}, {"name": "cpu_percent", "value": 13.582017543859646}]}, {"name": ".stage-files", "subtests": [{"name": "time", "value": 0.0007607936859130859}]}, {"name": ".run-tests", "subtests": [{"name": "time", "value": 4977.697282075882}, {"name": "cpu_percent", "value": 13.63514007092198}]}]}
[task 2022-08-11T15:38:24.855Z] 15:38:24     INFO - Total resource usage - Wall time: 4996s; CPU: 14%; Read bytes: 33064935424; Write bytes: 43862364160; Read time: 865911; Write time: 1685129
[task 2022-08-11T15:38:24.855Z] 15:38:24     INFO - TinderboxPrint: CPU usage<br/>13.6%
[task 2022-08-11T15:38:24.855Z] 15:38:24     INFO - TinderboxPrint: I/O read bytes / time<br/>33,064,935,424 / 865,911
[task 2022-08-11T15:38:24.855Z] 15:38:24     INFO - TinderboxPrint: I/O write bytes / time<br/>43,862,364,160 / 1,685,129
[task 2022-08-11T15:38:24.856Z] 15:38:24     INFO - TinderboxPrint: CPU idle<br/>45,244.3 (75.5%)
[task 2022-08-11T15:38:24.856Z] 15:38:24     INFO - TinderboxPrint: CPU system<br/>8,049.9 (13.4%)
[task 2022-08-11T15:38:24.856Z] 15:38:24     INFO - TinderboxPrint: CPU user<br/>6,656.5 (11.1%)
[task 2022-08-11T15:38:24.856Z] 15:38:24     INFO - TinderboxPrint: Swap in / out<br/>2,515,709,952 / 1,702,477,824
[task 2022-08-11T15:38:24.858Z] 15:38:24     INFO - start-pulseaudio - Wall time: 0s; CPU: Can't collect data; Read bytes: 0; Write bytes: 0; Read time: 0; Write time: 0
[task 2022-08-11T15:38:24.860Z] 15:38:24     INFO - install - Wall time: 20s; CPU: 14%; Read bytes: 263828992; Write bytes: 260943872; Read time: 16987; Write time: 394
[task 2022-08-11T15:38:24.862Z] 15:38:24     INFO - stage-files - Wall time: 0s; CPU: Can't collect data; Read bytes: 0; Write bytes: 0; Read time: 0; Write time: 0
[task 2022-08-11T15:38:24.926Z] 15:38:24     INFO - run-tests - Wall time: 4978s; CPU: 14%; Read bytes: 33033289728; Write bytes: 43587805184; Read time: 864227; Write time: 1684673
[task 2022-08-11T15:38:26.061Z] 15:38:26  WARNING - returning nonzero exit status 2
[taskcluster 2022-08-11T15:38:26.169Z]    Exit Code: 2
[taskcluster 2022-08-11T15:38:26.169Z]    User Time: 1h42m11.603739s
[taskcluster 2022-08-11T15:38:26.169Z]  Kernel Time: 1h19m9.765043s
[taskcluster 2022-08-11T15:38:26.169Z]    Wall Time: 1h25m19.048957s
[taskcluster 2022-08-11T15:38:26.169Z]       Result: FAILED
[taskcluster 2022-08-11T15:38:26.170Z] === Task Finished ===
[taskcluster 2022-08-11T15:38:26.170Z] Task Duration: 1h25m19.054473s
[taskcluster 2022-08-11T15:38:26.216Z] Uploading artifact public/logs/localconfig.json from file logs/localconfig.json with content encoding "gzip", mime type "application/json" and expiry 2023-08-11T13:42:49.732Z
[taskcluster 2022-08-11T15:38:26.479Z] Uploading artifact public/test_info/52EE659E-D828-4166-9585-333468641E47.dmp from file build/blobber_upload_dir/52EE659E-D828-4166-9585-333468641E47.dmp with content encoding "gzip", mime type "application/vnd.tcpdump.pcap" and expiry 2023-08-11T13:42:49.732Z
[taskcluster 2022-08-11T15:38:27.127Z] Uploading artifact public/test_info/52EE659E-D828-4166-9585-333468641E47.extra from file build/blobber_upload_dir/52EE659E-D828-4166-9585-333468641E47.extra with content encoding "gzip", mime type "application/octet-stream" and expiry 2023-08-11T13:42:49.732Z
[taskcluster 2022-08-11T15:38:27.231Z] Uploading artifact public/test_info/7B52476E-FEF0-4ED1-A2BC-3E991686D9F8.dmp from file build/blobber_upload_dir/7B52476E-FEF0-4ED1-A2BC-3E991686D9F8.dmp with content encoding "gzip", mime type "application/vnd.tcpdump.pcap" and expiry 2023-08-11T13:42:49.732Z
[taskcluster 2022-08-11T15:38:27.527Z] Uploading artifact public/test_info/BBE44D12-7EC0-4506-AD42-A6B7556265E5.dmp from file build/blobber_upload_dir/BBE44D12-7EC0-4506-AD42-A6B7556265E5.dmp with content encoding "gzip", mime type "application/vnd.tcpdump.pcap" and expiry 2023-08-11T13:42:49.732Z
[taskcluster 2022-08-11T15:38:27.732Z] Uploading artifact public/test_info/crashtest-test1_errorsummary.log from file build/blobber_upload_dir/crashtest-test1_errorsummary.log with content encoding "gzip", mime type "text/plain" and expiry 2023-08-11T13:42:49.732Z
[taskcluster 2022-08-11T15:38:28.034Z] Uploading artifact public/test_info/crashtest-test1_raw.log from file build/blobber_upload_dir/crashtest-test1_raw.log with content encoding "gzip", mime type "text/plain" and expiry 2023-08-11T13:42:49.732Z
[taskcluster 2022-08-11T15:38:51.285Z] Uploading artifact public/test_info/mozilla-test-fail-screenshot_obwpdc4n.png from file build/blobber_upload_dir/mozilla-test-fail-screenshot_obwpdc4n.png with content encoding "identity", mime type "image/png" and expiry 2023-08-11T13:42:49.732Z
[taskcluster 2022-08-11T15:38:51.381Z] Uploading artifact public/test_info/resource-usage.json from file build/blobber_upload_dir/resource-usage.json with content encoding "gzip", mime type "application/json" and expiry 2023-08-11T13:42:49.732Z
[taskcluster 2022-08-11T15:38:51.814Z] Uploading artifact public/test_info/system-info.log from file build/blobber_upload_dir/system-info.log with content encoding "gzip", mime type "text/plain" and expiry 2023-08-11T13:42:49.732Z
[taskcluster 2022-08-11T15:38:51.952Z] Uploading redirect artifact public/logs/live.log to URL https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/JMjftMqhRi2NwCHZbrREQw/runs/0/artifacts/public%2Flogs%2Flive_backing.log with mime type "text/plain; charset=utf-8" and expiry 2023-08-11T13:42:49.732Z
[taskcluster:error] exit status 2

:jjaschke, since you are the author of the regressor, bug 1700237, could you take a look?
For more information, please visit auto_nag documentation.

Flags: needinfo?(jjaschke)

On it.

Flags: needinfo?(jjaschke)
Assignee: nobody → jjaschke
Status: NEW → ASSIGNED

This bug fixes issues introduced in Bug 1700237 where the crashtest caused an infinite loop of JS exceptions.

Duplicate of this bug: 1784522
Summary: Intermittent TV TinderboxPrint: Per-test run of .../dom/base/crashtests/1700237.html<br/>: FAILURE → Intermittent TinderboxPrint: Per-test run of .../dom/base/crashtests/1700237.html<br/>: FAILURE
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch

This was a test-only change so comment 10 is impossible.

Flags: needinfo?(aionescu)

Thanks!

Flags: needinfo?(aionescu)
You need to log in before you can comment on or make changes to this bug.