accents are transformed into strange codes in all messages after clicking on a swf link in a message

RESOLVED DUPLICATE of bug 110729

Status

MailNews Core
Backend
RESOLVED DUPLICATE of bug 110729
15 years ago
9 years ago

People

(Reporter: pascalc, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Build 2002103004 WinXP

Steps to reproduce the bug
1 send to yourself an email with a link to a swf file,
http://home.attbi.com/~n9ivo/whatswrong.swf for instance
2 send to yourself a message containing accents such as 
é
à
è
ô
û
ö
ï 

3 Open the message with the accents, note that they are displayed correctly
4 Open the second message with the lonk, click on the link to the swf file in
MailNews, the swf file gets displayed in the message window
5 reopen the message with the accents, they are displayed like this:
é
à 
è
ô
û
ö
ï 

All messages in all my mailboxes now display wrongly accentuated characters. The
only way to get them displayed correctly (on a message per message basis) is to
force Charset coding to UTF8

Hee are the header lines concerning coding for the test message with the accents:

X-Accept-Language: en, fr-fr, en-gb, es-es
MIME-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8bit

Updated

15 years ago
QA Contact: gayatri → marina

Comment 1

15 years ago
dup of bug # 110729?

Comment 2

15 years ago
I could reproduce this bug on Linux RedHat 7.3 with updated mozilla packages :
mozilla-1.2.1-0_rh7
mozilla-mail-1.2.1-0_rh7
nautilus-mozilla-1.0.6-16
[...]
Changing Character encodig to UTF-8 for the message with accents leads to
the correct display.

Jean-Michel BARBET.
(Reporter)

Comment 3

15 years ago
setting OS to ALL following Jean-Michel's comment
OS: Windows XP → All
(Reporter)

Comment 4

15 years ago
this was indeed a dupe of bug 110729, it is now fixed.

*** This bug has been marked as a duplicate of 110729 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.