Mozilla overwrites soft link to bookmarks.html with file called bookmark.html

RESOLVED DUPLICATE of bug 156814

Status

SeaMonkey
Bookmarks & History
RESOLVED DUPLICATE of bug 156814
15 years ago
13 years ago

People

(Reporter: Mark Blackburn, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
On a linux system if you create a soft link (ln -s) to another bookmarks.html
file in you profile directory Mozilla starts fine and reads you bookmarks fine.
But when it exits it rewrites you bookmarks.html link with a file containing you
bookmarks.

I.E.:

$ pwd
/home/mark/.mozilla/default/blahblah.slt

$ ln -sf /win-d/home/mark/.mozilla/mark/blahblah.slt/bookmarks.html

$ ls -l bookmarks.html
lrwxrwxrwx   1 mark     users          58 Nov  5 10:46 bookmarks.html ->
/win-d/home/mark/.mozilla/mark/blahblah.slt/bookmarks.html*

-start Mozilla; bookmark a page; close Mozilla

$ ls -l bookmarks.html
-rw-r--r--   1 mark     users      215432 Nov  5 10:50 bookmarks.html

(bookmarks.html is now a file, not a link)

Expected behaviour: Mozilla should modify the file that the bookmarks.html link
points to.

Why this is important (IMHO): I'm using a dual boot system (Windows98 and linux)
but I only want to maintain one bookmarks.html file. So I figure I can have the
file on my Windows partition in my profile directory and in my Linux profile
directory I try to use a soft link to fool Mozilla into reading and writing to
my Windows bookmarks.html file. But alas, Mozilla sees through my subterfuge...

Comment 1

15 years ago
product: browser
component: bookmarks
summary: sym
status: any!

*** This bug has been marked as a duplicate of 156814 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.