Closed Bug 1784465 Opened 2 years ago Closed 2 years ago

[Quick Actions] View Source quickaction button is displayed twice

Categories

(Firefox :: Address Bar, defect)

Firefox 105
Desktop
All
defect

Tracking

()

VERIFIED FIXED
106 Branch
Tracking Status
firefox105 --- wontfix
firefox106 --- verified

People

(Reporter: cbaica, Assigned: daleharvey)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Found in

  • Fx105.0a1

Affected versions

  • Fx105.0a1

Affected platforms

  • all

Steps to reproduce

  1. Launch Firefox.
  2. In the address bar, type view source.

Expected result

  • The view source quick action button is displayed.

Actual result

  • The quick action button is displayed twice.

Regression range

  • Not a regression.

Additional Notes

  • The second quickaction button appears only when the entire keywords (view source) is typed.
Has STR: --- → yes
Assignee: nobody → dharvey
Status: NEW → ASSIGNED
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5c57a08e2303
Dont show duplicate QuickActions. r=daisuke
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 106 Branch
Flags: in-testsuite+

The issue is verified using the latest Fx106.0a1 build on Ubuntu 22, Windows 10 and macOS. Only one 'view source' button is displayed.

Status: RESOLVED → VERIFIED
No longer blocks: 1838617
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: