bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Keyboard arrow and spacebar navigation don't work after entering a URL before the page is completely loaded



Camino Graveyard
16 years ago
13 years ago


(Reporter: Mark Mentovai, Assigned: Mike Pinkerton (not reading bugmail))


Mac OS X





16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6

Immediately after entering a URL in the location bar and pressing Return,
keyboard arrow and spacebar navigation do not work.  Pressing the space bar or
arrows results in a beep, and no window movement.  Once the page is completely
loaded, keyboard and arrow navigation work.  If the mouse is clicked in the page
as it is loading, keyboard and arrow navigation work.

This also impacts accessibility.

This behavior isn't always easy to observe, as many pages complete loading too
quickly for the bug to manifest itself.  I have created a special page that
transmits 50 lines every 2 seconds so that this behavior can be more easily
observed.  It is available at http://www.mentovai.com/cgi/endless.cgi .

Reproducible: Always

Steps to Reproduce:
Type "http://www.mentovai.com/cgi/endless.cgi" in the Location bar and press Return.
Don't press or click anything other than the arrow keys or space bar.
When the vertical scrollbar appears, indicating that the space bar and arrow
keys should work, try pressing them.  They don't do what they're supposed to do,
instead, Chimera beeps.
Now click on the page itself and try the space bar and arrows.  They work.
Now try loading any other page without form controls that will get the focus and
let it load completely.  (The test page will never load completely.)  Notice
that once the page has loaded, the arrow keys and space bar work.
Actual Results:  
Chimera now beeps instead of scrolling the window.

Expected Results:  
Chimera should allow the use of the space bar and arrow keys consistently
throughout the application.

Chimera 0.6-2002110415

Comment 1

15 years ago
This works for me now. On the test page, I can hit spacebar as soon as the
scrollbar appears, and the page scrolls.
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 2

15 years ago
Pas moi.  Still broken in 0.6.0+-2002010104.  I can't scroll with the space bar
or arrows until I've clicked in the content area.

Resolution: WORKSFORME → ---

Comment 3

15 years ago
Confirmed using Chimera/2003021707. I closed all Navigator windows, opened one
new window, pasted the URL into the Location field, then pressed the space bar
when the vertical scroll bar appeared. Chimera then beeped, and didn't scroll.
Ever confirmed: true

Comment 4

15 years ago
there is a workaround, hitting tab once will focus the content area and arrow
keys work.
Assignee: saari → pinkerton
Target Milestone: --- → Future

Comment 5

13 years ago
I checked this on a variety of pages, page with and without form elements. And
it all works consistently. Old bug mozilla changes probably fixed this.

WFM using 2005020308 NB.
Last Resolved: 15 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.