Closed Bug 178473 Opened 18 years ago Closed 18 years ago

repeated events and exceptions fail

Categories

(Calendar :: General, defect)

x86
All
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Tony.Wilson, Assigned: mostafah)

References

Details

Attachments

(1 file)

If I have an event that repeats every week, and then add an exception so that it
misses one week, the calendar shows alarms for all the days up to the exception.

My example:
1) set an alarm at 18:40 on Tuesday.
2) set it to repeat every week (Tuesdays only)
3) add 12 Nov 02 as an exception date

Calendar now shows alarms for every day from Tue 5 Nov up to and including Mon
11 Nov.  Tue 12 Nov is missing (as required).  Tuesdays only shown from 19 Nov
onwards.
Can you please attach your .ics file to this bug?
You can get it from you Mozilla profile directory.
As requested this is my .ics file that demonstrates (at least on my machine)
the problem.  If you want, I can do any other tests.

Tony.
*** Bug 179914 has been marked as a duplicate of this bug. ***
->mostafa
Assignee: mikep → mostafah
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
This bug seems the same as 179698 and 179702. Seems redundant. (in this case,
transfer my vote!).
*** Bug 179698 has been marked as a duplicate of this bug. ***
*** Bug 179702 has been marked as a duplicate of this bug. ***
CVS seems to fix it. :-)
Attachment #105303 - Attachment mime type: application/octet-stream → text/calendar
Can anyone else confirm that this is fixed in CVS?
This seems to still be broken with the latest libxpical.so file I've got from
Mostafa.
My fault, I was linking to an old libxpical.so file
This is fixed in cvs. I'll make a new build with it fixed this afternoon.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
*** Bug 182322 has been marked as a duplicate of this bug. ***
I know this is late but I couldn't get calendar to install with the latest
nightly until last week.

I can also confirm that it WFM.
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: colint → general
You need to log in before you can comment on or make changes to this bug.