If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bad display corruption when scrolling long drop-down lists

RESOLVED DUPLICATE of bug 176297

Status

Camino Graveyard
HTML Form Controls
--
major
RESOLVED DUPLICATE of bug 176297
15 years ago
15 years ago

People

(Reporter: Chris Platts, Assigned: Brian Ryner (not reading))

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6

Scrolling long dropdown/popup/pulldown menus (whatever term you think tastes
best)  leads to nasy corruption including text being drawn over itself and the
underlying page being drawn over the menu.

[see screenshot attachment & 'Forum Jump' menu at bottom of test case URL]

Reproducible: Always

Steps to Reproduce:
1. Visit test-case URL, scroll to bottom
2. Click the Forum Jump menu
3. Point to the scroll arrow at the bottom of the menu
4. Scroll up & down a few times.  Yuck.

Actual Results:  
Text overwriting itself, uderlying page being redrawn over the top.

Expected Results:  
Displayed and scrolled the menu without corruption.
(Reporter)

Comment 1

15 years ago
Created attachment 105198 [details]
Example of menu scroll corruption.

Comment 2

15 years ago
Apparently WorksForMe using Chimera/2002110415 on 10.1.5. Could it have anything
to do with the ad IFRAME on the page? I have it blocked.
(Reporter)

Comment 3

15 years ago
I don't know the ins and outs of HTML layout, but I've tried a few more pages
and looked through their source to try to find out more.

At http://www.bbc.co.uk/ the 'Go straight to a BBC programme website' menu
exhibits the same behaviour, although it seems to take quite a few scrolls up
and down to break.  The code apparently uses only traditional tables (well, a
search for LAYER or IFRAME in the source came up empty :)
(Reporter)

Comment 4

15 years ago
Okay, some more info:

Having the BBC page open on its own, with no other tabs or windows, the menu
scrolls properly.

However, open the Gnutella forums page (the testcase URL with the iframe) in
*any* other tab or window, and the menu scroll breaks on the BBC page also.

Even if the IFRAME-containing page is in a minimised window, the problem still
occurs.

Also, when the menu is overwritten by the page contents, it is the page with the
iframe that is erroneously displayed.

Example:

1) Open www.bbc.co.uk in a fresh Navigator session (no other tabs or windows)
2) Test menu behaviour:  works fine
3) Open the testcase URL in another window.
4) Minimise the testcase URL window.
5) Test menu behaviour on the BBC page: Broken.  The menu is overwritten with
areas from the Gnutella page, even though that window is minimized.

Very odd.

Comment 5

15 years ago
I am experiencing this in a chinese newspaper site. I've already filed a bug for this. I'll try to 
provide the bug number later.
(Reporter)

Comment 6

15 years ago
Michael:

Got it - bug 176297

This bug seems to have narrowed things down a little more.  What's the etiquette
here for marking duplicates?  176297 was first, but this one seems a little
further developed, investigation-wise.

I'll post a pointer to this bug over on 176297, and leave it up to the powers
that be which bug they choose to dupe.  Whichever's better for the fixers.

Chris

Comment 7

15 years ago
You should mark this one a dup, and thereon add a brief summary of the new
information described here.
(Reporter)

Comment 8

15 years ago

*** This bug has been marked as a duplicate of 176297 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.