Closed Bug 1785117 Opened 2 years ago Closed 2 years ago

[css-values-4] Implement mod() and rem() functions

Categories

(Core :: CSS Parsing and Computation, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
109 Branch
Tracking Status
firefox109 --- fixed

People

(Reporter: sebo, Assigned: connor.pearson)

References

(Blocks 1 open bug, )

Details

(Keywords: dev-doc-needed)

Attachments

(1 file)

The CSS Values 4 specification defines two modulus functions mod() and rem().

This bug is meant to implement those.

There's also a related round() function, which is covered in bug 1764850.

I can work on this one.

Assignee: nobody → connor.pearson

Awesome, thanks!

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b749b19f919d
Implement CSS mod() and rem() functions. r=emilio
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/37228 for changes under testing/web-platform/tests
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 109 Branch
Upstream PR was closed without merging
Upstream PR merged by moz-wptsync-bot

Docs worked can be tracked here https://github.com/mdn/content/issues/22734

Duplicate of this bug: 1611577
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: