overflow:hidden behaves like visibility:hidden in mozilla 1.2a and later

RESOLVED DUPLICATE of bug 170040

Status

()

RESOLVED DUPLICATE of bug 170040
16 years ago
16 years ago

People

(Reporter: webmaster, Assigned: roc)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4

In the page at http://www.bolwin.com/segeln, the content of the navi-div is not
displayed. The style rules for that div (class="navi") is as follows:
.navi {position:absolute; top:0%; height:100%; left:0%; width:15%; overflow:hidden;}
after changing the overflow value to "auto", the content of the div is displayed.
omitting the overflow property is also resulting in a faulty behaviour (content
is not displayed) 

Reproducible: Always

Steps to Reproduce:
1. I wrote a test file containing one div only:
<div style="position:absolute; top:20%; height:10%; left:30%; width:30%;
overflow:hidden;">This ist a test</div> 
it works well.
2. Adding  the style rule: style="overflow:hidden;" to the body tag is resulting
in the faulty behaviour.




Expected Results:  
Mozilla should display the content of the div
to views.  I see this too, linux build 2002-11-01-21.  The size is correct, so
the content is _not_ overflowing....
Assignee: jst → roc+moz
Status: UNCONFIRMED → NEW
Component: DOM Style → Views
Ever confirmed: true
OS: Windows XP → All
QA Contact: ian → petersen
Hardware: PC → All
(Reporter)

Comment 2

16 years ago
I've found a workaround:
body {height:100%; overflow:hidden;}
leads to correct results.

the div is also displayed, setting its overflow value to "auto", however this
will not result in a disappearence of the scroll bars in any case.

The comments in the section of bug 170040 are a bit academically:
mozilla 1.0, 1.01 and 1.1 worked fine with: body (overflow:hidden;}

so what's wrong with mozilla 1.2a and higher?



*** This bug has been marked as a duplicate of 170040 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
Sorry:
body {height:100%; overflow:hidden;}
is only working in mozilla1.1 
Gecko 20020826 and earlier

in later versions only 
html {overflow:hidden;}
works.
You need to log in before you can comment on or make changes to this bug.