If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash on page load at wsmv.com [@ _ZN10nsRuleNode12...]

RESOLVED WORKSFORME

Status

Camino Graveyard
General
--
critical
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: kaldari, Assigned: saari (gone))

Tracking

({crash})

Details

(crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
I get a consistant crash when trying to load the following page using Chimera
0.6 (official release) on 10.2.1:

http://www.wsmv.com/Global/link.asp?L=63327&nav=1TcRCBXa
(Reporter)

Comment 1

15 years ago
Created attachment 105298 [details]
stack trace
(Reporter)

Updated

15 years ago
Keywords: crash
(Reporter)

Comment 2

15 years ago
Looks like the page uses lots of iframes and layers. I'll attach the page source
since the page isn't likely to stay up for very long.
(Reporter)

Comment 3

15 years ago
Created attachment 105299 [details]
HTML source of crashing page

Updated

15 years ago
Attachment #105299 - Attachment mime type: text/plain → text/html

Comment 4

15 years ago
Confirmed using Chimera/2002110415 on 10.1.5, generating the same stack. (Why
doesn't TalkBack run after this crash?)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: crash on page load at wsmv.com [@ _ZN10nsRuleNode12...] → Crash on page load at wsmv.com [@ _ZN10nsRuleNode12...]

Comment 5

15 years ago
test page (http://www.wsmv.com/Global/link.asp?L=63327&nav=1TcRCBXa) crashes:
stack trace is basically the same as that already posted.
Chimera 2002110949 & 10.2.x

Comment 6

15 years ago
This doesn't crash in a trunk mozilla build, but still crashes Chimera. I wonder
what trunk fix we need (searching for the host in the url in bugzilla doesn't
find anything).
That stack makes it look like the style context tree isn't a tree (and has
ancestor cycles).  I don't remember seeing that in the past.

When did Chimera branch?

Updated

15 years ago
Blocks: 201894
wfm on trunk
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ _ZN10nsRuleNode12...]
You need to log in before you can comment on or make changes to this bug.