If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

sidebar.cgi shouldn't prevent you from using it with incorrect UserAgent string

RESOLVED WONTFIX

Status

()

Bugzilla
Bugzilla-General
RESOLVED WONTFIX
15 years ago
7 years ago

People

(Reporter: Julian Hall, Unassigned)

Tracking

Details

(Reporter)

Description

15 years ago
Using Mozilla (buiild ID 2002110408) to access the bugzilla sidebar through a
proxy server that strips user agent headers returns the error 'sidebar.cgi
currently only supports Mozilla based web browsers'.

Please do not use this kind of test to determine whether or not my browser is
capable of seeing your site.  It is very annoying to those of us who _do_ know
what we're doing.
proposal (from myk) :  Error message stays, but it gets a button added to it
that says "try it anyway" or something to that effect, which adds an
"&override=1" on the end of the URL, which tells it to ignore the user-agent string.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Incorrect error message when using sidebar → sidebar.cgi shouldn't prevent you from using it with incorrect UserAgent string
(Reporter)

Comment 2

15 years ago
That sounds like a good idea, as long as there is an easy way to set the
override parameter to be on by default.
That won't work unless you change the js install stuff to point to that url.

Why do we need that check? sidebar.cgi isn't linked to from anywhere; the index
page uses js which will fail on non moz browsers anyway.
so where's the error coming from then?
sidebar.cgi generates the error. The sidebar install js identifies that file,but
I don't think its referred to from anywhere else. Doing so would be silly, since
loading it in the browser pane isn't really useful.

Comment 6

15 years ago
The idea behind putting that error in originally was to allow for future
expansion.  IE 6 is supposed to have the ability to have sidebars also (although
I don't know if it actually does 'cause  I try to use IE as little as possible
:).  In order for the same CGI to support an XUL sidebar for Mozilla and an HTML
one for IE, there has to be some way to tell the difference.  I filed bug 88067
at the time requesting a different way to tell if the browser accepts XUL, but
it was turned down.

Comment 7

15 years ago
*** Bug 181275 has been marked as a duplicate of this bug. ***
Reassigning bugs that I'm not actively working on to the default component owner
in order to try to make some sanity out of my personal buglist.  This doesn't
mean the bug isn't being dealt with, just that I'm not the one doing it.  If you
are dealing with this bug, please assign it to yourself.
Assignee: justdave → general
QA Contact: mattyt-bugzilla → default-qa

Comment 9

7 years ago
sidebar.cgi is gone in Bugzilla 4.2, and there is no plan to fix this on branches.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.