Autofill freezes Mozilla and passwords shown (not *'s)

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: wd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Overview Description:
The Autofill function seems to freeze up Mozilla for anywhere from 5 - 10
minutes, and also does NOT hide the password entered.   (It's shown as plain
text)

Steps to reproduce:
Go to http://www.slashdot.org
Enter login and password, having Mozilla remember these for use w/ Autofill
Exit Mozilla
Load up Mozilla again   and go to http://www.mozilla.org
Enter Autofill password and hit enter (And then click OK button!)

Actual Results:
Mozilla freezes up for a period of 5 to 10 minutes or so, probably eating up
100% CPU time.  (I don't have Wintop on this particular PC, so I'm not sure)
Pressing Enter after typing in Autofill password does nothing -- you are forced
to click the OK button
Once Mozilla becomes responsive again, the username and password are filled in
automatically, but with one problem:   The password is clearly printed in plain
text!   (No *'s)      (if you click on the password line with the mouse, it
changes to *'s)

Expected Results:
Autofill works quickly with no delays
Pressing Enter has the same effect as clicking OK
The password is masked by *'s

Build Date and Platform:
Mozilla build 1999110208
Windows 98

Additional Information:
This problem has appeared starting a few days ago.

-WD

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Comment 1

19 years ago
I assume that the line above that reads:

   and go to http://www.mozilla.org

is a typo and the reporter meant to say:

   and go to http://www.slashdot.org

With that correction, I am unable to duplicate part 1 of this bug report (long
delays).  I do see part 2 however and am investigating.

Very bizarre.  Seems to be happening with other sites as well (I just tried
bugsplat).  Looks like a regression in dialogs.
(Reporter)

Comment 2

19 years ago
Oops,  yes that URL in the description should be http://www.slashdot.org, not
mozilla.

Also, when I download a new nightly build, I just delete my Mozilla directory
and re-install over it.   Should I be clearing out any registry values, too?
(It does remember my autofill information, even after I delete my Mozilla
directory)

-WD

Comment 3

19 years ago
The signons are remembered in the user profile.  So you can either delete your
entire profile directory.  Or you can selectively delete the following files in
your profile directory:

   *.psw
   *.key
   *.tbl

Or the simplest thing you can do is to use the UI to modify the profile
(edit/wallet/view-signons and delete the saved signon).

Let me know if you are still seeing the long-delay problem because that I am
unable to reproduce.

Comment 4

19 years ago
If you want to delete your profile information, you would have to delete your
.mozilla directory. It's a good idea to delete this if you're ever having major
problems starting up or crashing or the like.

Regarding your 3 problems:

1. I can't reproduce this at slashdot, it prefills quickly for me after I press
OK. Do you see this at other sites also, or just slashdot?
2. The Enter problem is filed as bug 17569
3. I saw the same thing as you on Nov 02 build, but it seems fixed in Nov. 3
builds - please verify

Comment 5

19 years ago
Correction.  I just realized that there are three parts to your bug report and
not two (thanks to paulac's message).  When I said above that I see part 2 and I
called it very bizarre, I was referring to part 3 instead (the password coming
out in clear text instead of asterisks).

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 6

19 years ago
Yep, paulmac's right -- whatever the problem was for part 3, it is now fixed in
this morning's tree.  So I am closing out the report as works-for-me.

Part 2 is already covered in another bug report as paulmac mentioned.  That just
leaves part 1.  If you are still seeing the long delay, then please reopen this
report (or file a separate report on that problem) and I'll investigate further.
(Reporter)

Comment 7

19 years ago
I deleted my c:\users50 directory, and it works fine now.
(I had never noticed that directory before. . . )

-WD

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
verified worksforme with nov 03 build on win98

Comment 9

19 years ago
*** Bug 17860 has been marked as a duplicate of this bug. ***
Assignee: morse → nobody
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: paulmac → form.manager
Target Milestone: M11 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.