Closed Bug 1786460 Opened 2 years ago Closed 2 months ago

The video is missing on cnnportugal.iol.pt with ETP set to Strict

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

Firefox 105
Other
Android
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ctanase, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

Attached image CNN Portugal.png

Environment:
Operating system: Android 11 (ONEPLUS A6000)
Firefox version: Nightly 105.0a1-20220822095220

Preconditions:
• ETP set to STRICT
• Clean profile

Steps to reproduce:

  1. Go to https://cnnportugal.iol.pt/direto
  2. Observe the page.

Expected Behaviour:
The video loads on the page.

Actual Behaviour:
The video is missing from the page.

Notes:

  1. Screenshot provided.
  2. Not reproducible with Standard ETP.
  3. Same behaviour in Private.
  4. After switching from Standard back to Strict the video loads as expected.
  5. Reproducible on Windows 10 as well.

Tom, has this something to do with Bug 1781759? thanks.

Severity: -- → S3
Flags: needinfo?(twisniewski)

It seems so, as the video is in an IMA iframe, and I don't see the video in standard mode either in Firefox 103, but I see it in both modes on today's nightly (where that bug was just fixed). So let's close this as fixed for now.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(twisniewski)
Resolution: --- → FIXED

Tom the issue still occurs with ETP - Strict with latest Firefox Nightly build. Switching between Standard and Strict, the video will be shown, but after clearing cache ("Setttings>Delete browsing data"), the video will no longer be visible.
https://prnt.sc/K52IwneLrU4y

Note: With a clean profile and ETP - Standard the video is shown after accepting cookies.
https://prnt.sc/K0DC4AdkmX-Y
On ETP - Strict the popup to accept cookies is not triggered at all.

Tested with:
Browser / Version: Firefox Nightly 106.0a1 (🦎 106.0a1-20220824093620)
Operating System: Google Pixel 5 (Android 12) - 1080 x 2340 pixels, 19.5:9 ratio (~432 ppi density),

Reopening the issue.

Status: RESOLVED → REOPENED
Flags: needinfo?(twisniewski)
Resolution: FIXED → ---

The problem in comment #3 isn't reproducing for me anymore.

Status: REOPENED → RESOLVED
Closed: 2 years ago2 months ago
Flags: needinfo?(twisniewski)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: