If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

IMAP sub-folders broken between mozilla 1.2a and 1.2b

RESOLVED DUPLICATE of bug 147528

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 147528
15 years ago
9 years ago

People

(Reporter: Bill Gurley, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b)

My main email server is a remote IMAP server (Maildir format), where I have lots
of folders/sub-folders.  When I upgraded from mozilla 1.2a to 1.2b, I was
suddenly unable to expand hierarchical folders in the tree view.  The upper
level folder shows, but there is no triangle pointer beside it.  If I select a
message in my Inbox and click File to move the message to a subfolder, the
subfolders are accessible in this dialog.  Returning to 1.2a fixes the problem.
 Note:  yes, I do have a check in "Server supports folders that contain
sub-folders...".

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Assignee)

Comment 1

15 years ago
do you have "show only subscribed folders" turned on or not? If not, could you
try turning it on? All my sub-folders are working fine, and there are known
problems with not having "show only subscribed folders" turned on.
(Reporter)

Comment 2

15 years ago
I tried again.  Reinstalled 1.2b.  Changed my IMAP server setting by turning ON
"show only subscribed folders."  Restarted mozilla.  Problem persists.  I even
tried a different IMAP server (which uses a different server product) and
experienced the same problem.  Returned to mozilla 1.2a, and both IMAP servers
show nested folders just fine.
(Assignee)

Comment 3

15 years ago
sorry if this is a stupid question, but are you subscribed to the sub-folders?
Also, could you generate an imap protocol log?

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

(Reporter)

Comment 4

15 years ago
Actually, that was not such a stupid question!  I was subscribed to some of
them, not others.  But, alas, after making sure I was subscribed to all folders,
there was no change.  HOWEVER, I have something new to add:

I rebooted my linux PC, logged in as root and tried mozilla 1.2b and connected
to my regular IMAP mailbox.  The nested folders worked fine!  The only thing
that I could think of that was different was that, as root, I was using the
"classic" appearance theme.  As a normal linux user, I was using the "modern"
theme.  I logged back in as normal user, switched to "classic" theme, and now my
nested folders are back!  So, if this is a bug, it appears to be a bug with the
"modern" theme.  Thanks for your help.
(Assignee)

Comment 5

15 years ago
well, I'm glad it's working for you. I'm still at a bit of a loss, though. I run
with the modern theme and it's working fine for me. My gut feeling is that it's
an installation problem with the modern theme. If you create a new profile, does
that new profile work? I'm wondering if maybe the fastload file is corrupt,
XUL.mfl in your user profile directory.
(Reporter)

Comment 6

15 years ago
Just to be sure....

I created a new linux user, restarted KDE with that user logged in.  Ran mozilla
1.2b;  switched to the "modern" theme;  restarted mozilla; set up the same IMAP
email account.  Initially it seemed to load all of the nested folders in the
left frame.  But after I collapsed all of them, the triangle went away and they
would not come back.

I have downloaded a bunch of themes from mozdev.org (the ones that say that they
are compatible with 1.2).  Most of them exhibit the same problem. Presently I am
using "Orbitz 3+1 1.2 0.0.6.5-dev" and it works with the nested folders.
(Reporter)

Comment 7

15 years ago
A followup:

My earlier comments were based on my experience with my office computer at work.
 This evening I got home and experimented with my home machine.  Both computers
are Redhat 7.3 and KDE3.  At home I was still running mozilla 1.1 with the
modern theme.  I upgraded to 1.2a, and I have the same problem with nested
folders as on my office machine.
(Assignee)

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
QA Contact: huang → gchan

Comment 8

15 years ago
Created attachment 110855 [details]
IMAP protocol log

Attached is an IMAP protocol log. Mozilla 1.2.1 on Windows, connecting to
courier-imap (maildir) on Linux. Settings: SSL is on, "Show only subscribed
folders" is off, namespaces are set to their defaults ("INBOX." and "shared.",
respectively), "Server can override..." is on.

I am having similar problems: only the first and second folder levels below
INBOX are displayed. The problem occurs in the main folder tree, the
subscription dialog box, and the File button or context menu option. I remember
that when I installed and configured Mozilla the third level was available; on
one of the next startups the folders simply disappeared.

The protocol log shows that only INBOX.% AND INBOX.%.% are queried. Even though
for example the mailbox "INBOX.Nieuwsbrieven.Winkels" has subfolders
(\HasChildren), these are neither queried (one would expect with INBOX.%.%.%)
nor displayed.

Mozilla 1.0 on Linux, connecting to the same IMAP-server, displays the same
symptoms; the log is similar. On Linux I am using the debian packages for
woody.
(Assignee)

Comment 9

15 years ago
please try a newer trunk build. this should be fixed now (though you may need to
delete your .msf files in the sub-directories to get the fix since the fix
involves how we deal with newly discovered folders)

Comment 10

15 years ago
marking this bug as dupe of bug 147528.

I verified the other bug and things seem to be working fine.

*** This bug has been marked as a duplicate of 147528 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 11

15 years ago
I'm still seeing nested folder problems on the trunk.  See my comments in bug
147528.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.