luhs.org - "Map" links don't work, bad JS syntax

RESOLVED INVALID

Status

P4
normal
RESOLVED INVALID
16 years ago
4 years ago

People

(Reporter: jkahlo1, Unassigned)

Tracking

Details

(Whiteboard: [SYNTAX-JS], URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021105
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021105

The red Map links should use Javascript to Popup a new window and display the map.
This also happens in Phoenix .4

Reproducible: Always

Steps to Reproduce:
1. Visit URL
2. Click on noted links
3.

Actual Results:  
No response to click on link.

Expected Results:  
Popup a new window showing the map.

Comment 1

16 years ago
Hum
On page load:
Error: syntax error
Source File: http://www.luhs.org/maps/index.htm
Line: 12, Column: 7
Source Code:
End -->

On Map clicking:

Error: openWindow is not defined
Source File:
javascript:openWindow('../maps/lumctour/maps/cancerctr.htm','list','width=675,height=650')
Line: 1

the first error prevents the definition of openWindow

<!-- Begin
function openWindow(url,target,size) {
parameter = 'toolbar=no,resizable=yes,scrollbars,location=no,' + size
	newWin = window.open(url,target,parameter);
}
End -->

The last line should be
//End -->


Mac OS 9.1 Build 2002110408


Evangelism ?
Many pages have bad script ending. Mozilla is very sensitive about that.

*** This bug has been marked as a duplicate of 81935 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
Can Evangelism take this? This was found by a co-worker of mine and he thinks
the problem is with Mozilla. Maybe there should be an "Almost Standards" mode
for JavaScript. :-)

Comment 4

16 years ago
reopen and assign to te (see bug 81935)
Status: RESOLVED → UNCONFIRMED
Component: Browser-General → US General
Product: Browser → Tech Evangelism
Resolution: DUPLICATE → ---
Summary: "Map" links don't work. → uhs.org - "Map" links don't work.
Version: other → unspecified

Comment 5

16 years ago
mine
Assignee: asa → bclary
QA Contact: asa → susiew
Whiteboard: [SYNTAX-JS]

Comment 6

16 years ago
Marking new per previous comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4
Summary: uhs.org - "Map" links don't work. → luhs.org - "Map" links don't work, bad JS syntax

Comment 7

16 years ago
tech evang june 2003 reorg
Assignee: bc → english-us
QA Contact: susiew → english-us

Comment 8

5 years ago
The links on the map seem to work now. Bug no longer present. Closing.
Status: NEW → RESOLVED
Last Resolved: 16 years ago5 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.