Closed Bug 1787531 Opened 2 years ago Closed 2 years ago

POP new mail notification no longer ignores mails marked as read or junk via message filters

Categories

(Thunderbird :: Preferences, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr102+ fixed, thunderbird107 fixed)

RESOLVED FIXED
108 Branch
Tracking Status
thunderbird_esr102 + fixed
thunderbird107 --- fixed

People

(Reporter: earlgreypicard, Assigned: rnons)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent:
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:102.0) Gecko/20100101 Thunderbird/102.2.0

Steps to reproduce:

  1. Start Thunderbird 102.
  2. Set up any POP account.
  3. Open "Settings > General > Incoming Mails" and set the following:
    • Change preferences for the app icon
      • [x] Show badge icon
      • Badge app icon with:
        • [ ] Count of unread messages
        • [x] Count of new messages
    • [x] Show an aler
      • [ ] Use the system notification
    • [x] Show a tray icon for unread messages
    • [x] Play a sound
  4. Create a message filter that actions "Mark As Read"
  5. Send a mail that matches the rule.

Actual results:

Plays new mail sound, shows badge and tray icon.
Alert is not shown (ignoring emails marked as read).

Expected results:

Don't play sounds or show badge and tray icon.
Same behavior as "mailnews.pop3.jsmodule=false"

I have more to report.
Previously, new mail notifications were completely ignored when Message Filters did the "Set Junk Status to Junk" action.
With "mailnews.pop3.jsmodule=true", new mail notification is performs even for junk mail.

The behavior of ignoring new mail notifications in POP is summarized below.

[ mailnews.pop3.jsmodule=false ]

Filter action Sound Alert Badge Tray icon
Mark As Read don't play don't show don't show don't show
Set Junk Status to Junk don't play don't show don't show don't show

[ mailnews.pop3.jsmodule=true ]

Filter action Sound Alert Badge Tray icon
Mark As Read play don't show show show
Set Junk Status to Junk play show show show
Regressed by: pop3-js
Summary: New mail sound and app icon are not ignoring mails marked "As Read" in Message Filters → POP new mail notification no longer ignores mails marked as read or junk in Message Filters

(In reply to EarlgreyTea from comment 0):

Expected results:

Don't play sounds or show badge and tray icon.

I don't understand. In your STR, the following are checked:

[x] Show badge icon
[x] Show a tray icon for unread messages
[x] Play a sound

Why do you expect the opposite of your settings to happen (no sound, no badge, no tray icon)?

I understand the filter issue with the new POP implementation Needs testing.

Severity: -- → S3
Component: Untriaged → Preferences
Flags: needinfo?(earlgreypicard)
Summary: POP new mail notification no longer ignores mails marked as read or junk in Message Filters → POP new mail notification no longer ignores mails marked as read or junk via message filters

(In reply to Thomas D. (:thomas8) from comment #2)

(In reply to EarlgreyTea from comment 0):
I don't understand. In your STR, the following are checked:

[x] Show badge icon
[x] Show a tray icon for unread messages
[x] Play a sound

Why do you expect the opposite of your settings to happen (no sound, no badge, no tray icon)?

Because that was the behavior in Thunderbird 91.
Messages marked as read or junk by the message filter are ignored by new mail notification.
And users are setting message filters expecting that result.

Flags: needinfo?(earlgreypicard)

I think this behavior is related to bug 11040

I'm new here, so forgive my ignorance. Is this bug on some path to being fixed? It was only introduced two (or so) releases back, so one might assume there's a clear place to look.

And to Thomas D., the notifications are for "real" messages, i.e., not ones filtered directly to trash.

Let me take a look

Assignee: nobody → remotenonsense
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → 108 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/99dc129c1c5c
Show no notification for mails marked as read or junk by filters in pop3-js. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

(In reply to Pulsebot from comment #10)

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/99dc129c1c5c
Show no notification for mails marked as read or junk by filters in pop3-js. r=mkmelin

Confirmed fixed in Daily 108.0a1 (2022-11-05).
When will this fix be released in esr102 ?
A user who contacted MozillaZine.jp about this issue is looking forward to a fix.
https://forums.mozillazine.jp/viewtopic.php?f=3&t=20223

Comment on attachment 9300687 [details]
Bug 1787531 - Show no notification for mails marked as read or junk by filters in pop3-js. r=mkmelin

[Triage Comment]
Let's get this on today's beta so it can potentially go into an upcoming 102 release.

[Approval Request Comment]
Regression caused by (bug #): pop3-js
User impact if declined: Issues with POP mail notifications
Testing completed (on c-c, etc.): Confirmed fixed in Daily
Risk to taking this patch (and alternatives if risky):

Ping: any objections?

Attachment #9300687 - Flags: approval-comm-esr102?
Attachment #9300687 - Flags: approval-comm-beta+

Comment on attachment 9300687 [details]
Bug 1787531 - Show no notification for mails marked as read or junk by filters in pop3-js. r=mkmelin

[Triage Comment]
Approved for esr102

Attachment #9300687 - Flags: approval-comm-esr102? → approval-comm-esr102+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: