If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Suntrust blocks Mozilla, not based on User Agent string.

RESOLVED DUPLICATE of bug 73894

Status

Tech Evangelism Graveyard
English US
RESOLVED DUPLICATE of bug 73894
15 years ago
3 years ago

People

(Reporter: Jase Roberts, Assigned: Arun Ranganathan)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

http://www.suntrust.com/ blocks Mozilla.  Using the User Agent switching tool at
http://uabar.mozdev.org/ to emulate IE does not fix this. 
https://internetbanking.suntrust.com/ lets Mozilla through.  Based on the
"Browser Check" link on that page, looks like Suntrust is using
"document.write(navigator.appName + " " + navigator.appVersion)" to check
browsers.  Dumb, but I'm really glad that the actual online account part doesn't
block moz.

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.suntrust.com/ using Mozilla



Actual Results:  
You get an error page:
Your browser is not compatible with www.suntrust.com at this time.
If you are using Netscape 6.x, Netscape has chosen to alter their communication
standards resulting in this incompatibility. In the interim, we recommend you
use one of the following browsers: 

Expected Results:  
They should have let me in.

Comment 1

15 years ago
we have been working to get them to allow Mozilla and other Gecko based browsers
into their site. Please help by complaining to them directly.

*** This bug has been marked as a duplicate of 73894 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
Moving to new component
Component: US Banks → English US
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.