Closed Bug 178820 Opened 18 years ago Closed 16 years ago

return-receipt-to not recognized with IMAP mailbox

Categories

(SeaMonkey :: MailNews: Backend, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: thomas, Assigned: wolfiR)

References

Details

(Keywords: fixed-aviary1.0)

Attachments

(1 file)

Mozilla 1.1 / Linux SuSE 8.0

I use a exchange server with imap.
When a user who works with oulook sends a email with "Return-Receipt-To:" the
mozilla does not send a notification to the sender. If i use the mozilla with a
pop server the return receipt works fine.

If i send a mail with my mozilla-mail to me itself with e "return receipt
request" the return receipt was send to me. Mozilla sends not a
"Return-Receipt-To", they sends a "Disposition-Notification-To:".

Mail send with return receipt and deliverd by Exchange/IMAP:
From              To             
outlook           mozilla         - No notification
mozilla           mozilla         - notification was send
mozilla           outlook         - No notification

Mail send with return receipt and deliverd by sendmail/pop
From              To             
outlook           mozilla         - notification was send
mozilla           mozilla         - notification was send
mozilla           outlook         - No notification

Regards,
Thomas
Reporter,
I don't have ms exchange server to test with.

But using a netscape mesg server,
I was able to use mozilla 1.1 on linux 2.2, red hat 7.0
and I was able to send a mesg w/return receipt request to a outlook
user and get the read receipt mesg back.

I was also able to receive a mesg from an outlook user, that had a
Return receipt request, I got prompted, i sent the request back,
and the outlook user was able to receive the mesg.

and yes mozilla sends a "Disposition-Notification-To:". but
that shouldn't be a problem as I was able to use return receipts
with no problems.


Assignee: mscott → bienvenu
Component: Mail Notification → Return Receipts
QA Contact: stephend → gchan
Hello,

here you can see the sourcecode of a mail wich was send from outlook and
received by mozilla. No notifycation was send to the sender(outlook). Mailserver
= MS-Exchange.

---------------
Received: by ntserver1 
	id <01C286F6.E49AC420@ntserver1>; Fri, 8 Nov 2002 08:17:27 +0100
Message-ID: <B358BA3A88AED111831400A0C9A7B0520129825B@ntserver1>
From: Herpaadmin <Herpaadmin@herpa.de>
To: =?iso-8859-1?Q?G=F6bel_Thomas?= <GoebelT@herpa.de>
Subject: test
Date: Fri, 8 Nov 2002 08:17:27 +0100 
Return-Receipt-To: Herpaadmin <Herpaadmin@herpa.de>
MIME-Version: 1.0
Content-Type: text/plain;
	charset="iso-8859-1"

test
------------------

Please tell me what test i can do for you!

Regards,
Thomas
Hello,

what can be done know.
Now i have installed Mozilla 1.2.1 an it still doesn`t work?

If i send a mail in the following way 
outlook->exchange->smtp->pop->mozille 
i get a return receipt message.
If i send the mail in the way
outlook->exhange->imap->mozilla
i get NO return receipt.

Regrads,
Thomas
reporter using 
commercial trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021213 on xp
and linux trunk
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021213

with Outlook Express 6.0 or Outlook 2000 and Microsoft Exchange IMAP4rev1 server 
version 5.5.1960.6

I had no problems doing the following:

either outlook mail tool-> mesg w/ret cept to mozilla imap user on MS Exchange 
server
   (i got a ret recpt prompt and sent it with no problem)
Nor the opposite:

Mozilla imap w/MS Exchange server with a ret recpt mesg -> Either Outlook mail 
tool
 (the outlook express user was prompted for ret recpt mesg)

this works for me.

Reporter try a new profile?
Are you using outlook express or outlook?

try updating to 1.3a.
Hello,

i have create a new profile. i leave all options as standard(return receipt and
all other options)

I hav send a email with a client outlook 2000 wich is connected to an Exchange
5.0 Server.
Then i receive the mail with mozilla 1.2.1 wich uses the exchange server by imap.

No return receipt was send. No question "Sender requests a return receipt, would
you send it" was displayed. Also the setting "send return receipt without ask
me" does not work.

-----------------

Then i send a second message to my home email-account with outlook 2000 through
the exchange server.
(outlook->exchange->smtp->pop->mozilla)
Now the return receipt was send!!! Mozilla ask me if i will notify the sender.

-----------------

If i send email with "return receipt" with mozilla to myself. The return receipt
works also fine.
(mozilla->exchange(smtp)->imap->mozilla)

------------------

The only differences between the mail wich sends outlook and wich was send by
mozilla are:

outlook: Disposition-Notification-To: Thomas Goebel <goebelt@mydomain.de>
mozilla: Return-Receipt-To: Herpaadmin <admin@mydomain.de>

------------------

Im not a developer, but it seems, that the "Return-Receipt-To:" has no effect if
the mail was received by imap(exchange). Only the "Disposition-Notification-To:"
works fine with imap.

BTW: Today i will upgrade to 1.3a

Regards,
Thomas
yes, we're not requesting the return-receipt header - should be easy enough to fix
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Ok I think i am finally seeing the problem.
What's weird is that this is a linux (12/18 trunk) & mac (12/16 trunk) only 
problem. When I use windows build (12/18 trunk) I don't see this.

I set up 2 mail accounts, both imap, both using the same MS exchange
server. I am using Outlook 2000.

Acnt 1 is on Outlook.
Acnt 2 is on mozilla.

on mac and linux:
When I send a mesg (w/ret recpt) from Mozilla to Outlook:
  -when I open it up in Outlook, I get prompted to send a Ret Recept
  -i say send
  -BUT when i go to Mozilla I never receive the ret recpt mesg

When I send a mesg (w/ret recpt) from Outlook to Mozilla:
  -when I open the mesg in Mozilla, I get prompted for R.R.
  -i say send
  -I receive the Ret. Recpt mesg in Outlook

Windows it works as expected? Don't know what I'm missing.
Key is both mail acnts have to be on MS exchange server. I
didn't see this when I was using one acnt on Exchange server and
another acnt on Netscape Mesg server.




The problem you descriped is NOT the same i have.

You wrote, that you send a mail FROM Mozilla TO Outlook. Outlook will notify the
sender but Mozilla does not receive a notification.

This is also a problem, but this is not the problem i see.

My problem are, that if you send a message with Outlook(Exchange connection) to
Mozilla(Imap-Exchange) you will not receive a return receipt. Mozilla DON`T ask
me to send a notification to the sender.
If i send a mail with Outlook(Exchange connection) to a external mailaccount
where i receive the mail with Mozilla(pop) i receive a return receipt notification.

Please read my update on "2002-12-17 23:51" , "2002-11-07 02:20" again.

So,i think we have to problems. Maybe the same Bug.

1.) Mozilla don`t send a ret recpt to Outlook (Exchange-Imap) 
2.) Outlook don`t send a ret recpt to Mozilla but ask me to send one.

Regards,
Thomas

ok reporter, 

I don't see the problem as mozilla always asks me
if I want to send a notification back when i send from
outlook (imap exchange) to mozilla (imap exchange).

the only problem i see is the one mentioned in comment 7
Hi,

my outlook 2000 is configured to use the Exchange connector not the Imap port of
the Exhange server. Don`t know if there is any difference?

Is there anything i can do for you to find the problem i have descriped? Like,
network sniffing with ethereal.

Regards,
Thomas
Hi,

the Bug ist still present in

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

No returnt receipt message was send. This is a big problem for us (me). All
outlook users wish to see the return receipt message. If this problem shoudl not
fixed in the next weeks. I have to use outlook and IE! 
And that`s what i really don`t want to use.

Regards,
Thomas
nominating..
Keywords: nsbeta1
OS: Linux → All
Mail triage team: nsbeta1-
Keywords: nsbeta1nsbeta1-
Hi,

now i have tested the
" Mozilla 1.4 - Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030626"
release.

And the Bug is still present!!!

Regards,
Thomas
*** Bug 227795 has been marked as a duplicate of this bug. ***
Hi,

i would just inform you, that this bug is still present in 
Mozilla 1.6 / Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040114

Regards,
Thomas
Hardware: PC → All
Hi,

i would just inform you, that this bug is still present in 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040804

Regards,
Thomas
Assignee: bienvenu → mozilla
changed summary to describe base problem
Summary: return receipt does not work with outlook/exchange IMAP → return-receipt-to not recognized with IMAP mailbox
Attachment #162982 - Flags: review?(dmose)
Comment on attachment 162982 [details] [diff] [review]
simple fix to recognize Return-Receipt-To

I've decided I'd prefer that bienvenu look at this one, as he's got
significantly more context about this issue than I.  However, assuming he likes
it, sr=dmose.
Attachment #162982 - Flags: superreview+
Attachment #162982 - Flags: review?(dmose)
Attachment #162982 - Flags: review?(bienvenu)
Comment on attachment 162982 [details] [diff] [review]
simple fix to recognize Return-Receipt-To

r=bienvenu
Attachment #162982 - Flags: review?(bienvenu) → review+
Comment on attachment 162982 [details] [diff] [review]
simple fix to recognize Return-Receipt-To

because it's very low risk I think this could go to the branches as well.
After this decision I would need anyone to check this in as I have no CVS write
access. Thanks.
Attachment #162982 - Flags: approval1.7.x?
Attachment #162982 - Flags: approval-aviary?
Comment on attachment 162982 [details] [diff] [review]
simple fix to recognize Return-Receipt-To

If david thinks this is worth taking on the branches, he's got approval.
Attachment #162982 - Flags: approval1.7.x?
Attachment #162982 - Flags: approval1.7.x+
Attachment #162982 - Flags: approval-aviary?
Attachment #162982 - Flags: approval-aviary+
David, would you please check this in?
Assignee: mozilla → bienvenu
Status: ASSIGNED → NEW
Checked in on trunk:

Checking in mailWindowOverlay.js;
/cvsroot/mozilla/mailnews/base/resources/content/mailWindowOverlay.js,v  <-- 
mailWindowOverlay.js
new revision: 1.205; previous revision: 1.204
done
Assignee: bienvenu → mozilla
David, do you think this is worth getting in TB 1.0? 
yes, I can do that...
Product: Browser → Seamonkey
*** Bug 271820 has been marked as a duplicate of this bug. ***
*** Bug 264854 has been marked as a duplicate of this bug. ***
*** Bug 242519 has been marked as a duplicate of this bug. ***
I just ported this patch to thunderbird. Branch and Trunk. Let me know if I
shouldn't have done that David :)

Can we resolve this bug now that this patch is in the suite and in thunderbird?
yes, that was the right thing to do, thx, Scott.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Keywords: fixed-aviary1.0
This bug is certainly NOT fixed in TB1.0 - RR work on outbound mail but NOT inbound.
(In reply to comment #33)
> This bug is certainly NOT fixed in TB1.0 - RR work on outbound mail but NOT
inbound.

This should be a blocker.
Flags: blocking-aviary1.1?
I also witness that bug 271820 has not been fixed in TB1.0

Bug 271820 has been marked as a duplicate of this but left as UNCONFIRMED.

However, this bug has been closed.

This bug refers to IMAP. Bug 271820 refers to POP3. Whether that is relevant I
don't know but

a) that problem still exists on TB1.0 under Win XP SP2
b) two people at least have here already commented very firmly that it should
not be closed because it is not fixed.
c) This was closed and 271820, which had been marked as a duplicate implicitly
closed as a result but left as UNCONFIRMED even though it has been recognized as
related to this for which a patch was raised.
Bug 271820 is not fixed. Please re-open this (and include the nature of 271820
in this problem) or 271820 (and recognize that in its STATUS) or both. Thank
you. RDL
*** Bug 277353 has been marked as a duplicate of this bug. ***
(In reply to comment #35)
> I also witness that bug 271820 has not been fixed in TB1.0
> Bug 271820 has been marked as a duplicate of this but left as UNCONFIRMED.
> However, this bug has been closed.
> This bug refers to IMAP. Bug 271820 refers to POP3. Whether that is relevant I
> don't know but
> 
> a) that problem still exists on TB1.0 under Win XP SP2
> b) two people at least have here already commented very firmly that it should
> not be closed because it is not fixed.
> c) This was closed and 271820, which had been marked as a duplicate implicitly
> closed as a result but left as UNCONFIRMED even though it has been recognized as
> related to this for which a patch was raised.
> Bug 271820 is not fixed. Please re-open this (and include the nature of 271820
> in this problem) or 271820 (and recognize that in its STATUS) or both. Thank
> you. RDL

Agreed - 271820 is NOt a duplicate, and should stay open until it is fixed.


I've now checked this out again with mozilla 1.8a5 and thunderbird 1.0.
It worked for me with IMAP and with POP3.

Could anyone please explain exactly what does still not work?
What means "inbound" and "outbound" mail in that environment.
Inbound - Mail coming in to the TB client. If it contains a header requesting
the TB recipient send a "read receipt" and recipient has settings to be prompted
for choice of action (send/don't send) in this situation then TB ignores the header.

Outbound - Mail sent by the TB client. If sender has settings to include a
request for a "read receipt" from the addressee (recipient) then the appropriate
header is included OK and a recipient on eg IE (but not TB) will get the prompt
if their settings specify that response.

If you are on TB 1.0 standard general release and not a later nightly then I am
puzzled that you are getting prompted using POP3. Please see further info now
emerged in Bug 273356 where a patch is announced but it unintentionally missed
the general release.

Please also see further received from David Bienvenu re:

https://bugzilla.mozilla.org/show_bug.cgi?id=277353

------- Additional Comments From bienvenu@nventure.com  2005-01-06 21:26 PST 
-------
this was fixed after tbird 1.0, not *in* tbird 1.0 - please try a post 1.0 
build
from here:

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-0.9/


I have not had a chance to reply his latest and of course he is talking with me
about POP3, where I have a regular correspondent on TB 1.0 and also POP3 and who
also still has the problem. Hopefully the patch included at above will fix the
problem but I have other (Symantec) diversions to keep me from venturing off the
 main road at the moment!

Hope this helps to clarify. RDL
thanks. So as this bug is only meant for IMAP and inbound recognition it's
marked as fixed correctly.
And as I didn't use a Global Inbox in my POP3 test it worked for me for POP3, too.
as it is actually fixed in trunk I've removed the blocking-aviary1.1 ? flag.
But could someone please check this in for 1.7.x. The patch got approval for
1.7.5 but was missed.
Flags: blocking-aviary1.1?
Component: MailNews: Return Receipts → MailNews: Backend
QA Contact: grylchan → offline
You need to log in before you can comment on or make changes to this bug.