Closed Bug 1788273 Opened 2 years ago Closed 2 years ago

Tweak popup alignment so that Wayland mirroring works bettter.

Categories

(Toolkit :: UI Widgets, task, P3)

task

Tracking

()

RESOLVED FIXED
106 Branch
Tracking Status
firefox106 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When you have a wayland popup aligned to the bottomcenter topleft as we have e.g. for the library menus, we can't come up with a request such that we end up mirroring correctly, see bug 1784876 for an example.

But we no longer have arrows on the panels and we really want the sides to align, so we can change the alignment properties and remove the large negative margins, which would allow Wayland to properly mirror them.

When these panels had arrows, I guess the bottomcenter topleft alignment
made sense so that you could precisely align the arrow, but that's not
what we do now.

Don't use bottomcenter / leftcenter / rightcenter, since we really want
the sides to align.

This shouldn't change behavior on any platform except Linux + Wayland,
where the alignment looks good now in the case of bug 1784876.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/368a7ce1b104
Tweak popup alignment so that it looks good on mirrored wayland popups. r=dao,mak
Priority: -- → P3
Attachment #9292491 - Attachment description: Bug 1788273 - Tweak popup alignment so that it looks good on mirrored wayland popups. r=Gijs,dao,mak → Bug 1788273 - Tweak popup alignment so that it looks good on mirrored wayland popups. r=dao,mak
Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2796340b53b8
Tweak popup alignment so that it looks good on mirrored wayland popups. r=dao,mak
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 106 Branch
Regressions: 1789278
See Also: → 1718011
Regressions: 1790015
Regressions: 1817669
You need to log in before you can comment on or make changes to this bug.