Closed Bug 178884 Opened 17 years ago Closed 7 years ago

Bookmarks-toolbar-part with folders can get into a resize-loop when on the menubar

Categories

(Firefox :: Toolbars and Customization, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: tuukka.tolvanen, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021107 Phoenix/0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021107 Phoenix/0.4

A bookmark folder on the bookmarks toolbar-part on the menubar appears to make
it 1px taller; when the last folder is replaced by the '>>' bit (um is that
called the chevron or...?), the menubar gets confused about its height

Reproducible: Always

Steps to Reproduce:
 1. Add a bookmark folder on the bookmark toolbar if there isn't one already
 2. Place the bookmark-toolbar-part on the menubar, right of the menu
 3. Resize the window horizontally down until the '>>' menu bit is replacing
    the leftmost folder on the bookmark-toolbar-part

Actual Results:  
Sit still

Expected Results:  
bm-tb-part can't decide between '>>' and folder; menubar's height, and
all window content below it, vibrates by 1px.
s/actual/expected/ and vice versa, though ;)
confirming with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021104
Phoenix/0.4
Status: UNCONFIRMED → NEW
Ever confirmed: true
I think this is the correct bug that I am experiencing.

Windows 2000. Phoenix 0.5. Noia theme. 

Here's what happens to me:

1) Fill up your bookmarks toolbar (the bar across the top where you drag your
most often clicked bookmarks) so that you have bookmarks across the width of the
toolbar when the browser in normal maximized mode.

Make it so that it's filled, but not to the point where it causes the browser to
place the next item in the bar off to the side in a drop down menu and then put
the little arrows (like this ">>") there.

Now manage bookmarks, highlight the personal toolbar folder, and create a new
folder there. It has to be a folder and not just another bookmark.

Close the manage bookmarks screen and your browser (the main window and the
right main scrollbar) should be jumping up and down a pixel or two at maybe 200
beats per minute.

The new folder you created will now be in the ">>" drop down menu area of the
Bookmarks Toolbar. 
i've posted a capture of what it looks like in the mozillazine forum:
http://www.mozillazine.org/forums/viewtopic.php?p=53520#53520

the main window and scrollbar, and the site icon in the urlbar are affected. 
they don't actually "bounce."  the top line gets doubled, and the rest gets
forced down one line, and the top line of the status bar disappears.  the
bouncing occurs at different speeds in different occurances.

one time i resized the window vertically, and the status bar disappeared, making
it stop bouncing - but i couldn't repeat it.

it only seems to happen in certain themes.  confirmed so far:
pinball 
chimera
noia

it doesn't occur in these:
luna
luna blue
phoenity aqua
qute
minimalist
safari (and it's variants)
I'm pretty sure this WFM in FB 0.6.1rc1 (Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.5a) Gecko/20030725 Mozilla Firebird/0.6) but we could probably
do with some verification and some decent test cases.

Still, it seems to be a skin issue so it maybe should be closed.
nope.  still get it in 20030725-1.5a with Pinball 0.6.6 theme.  put bookmarks
toolbar items on menubar, with a folder just after the chevron.  had been using
0.6 milestone and 20030611 nightly for a while and thought it had gone away. 
but just tried it again with fresh profiles and got it to happen in 0.6
milestone, 20030611, 20030725-1.5a (0.6.1rc).  but it's unreliable - after
certain toolbar customizations, can't get it to happen anymore.

but it is definitely theme-dependant.  now that i'm more knowledgeable with
themes, i'll see if i can track down what causes it.

just found that it doesn't occur if there's a button following the bookmarks on
the menubar; spaces and separators don't fix it.

this also seems to expose another possible bug - objects placed after the
bookmark toolbar items get forced all the way over, like a flex-space, even if
there's plenty of free room.  but unlike a flex, if the bookmarks take up all
the space, the following object isn't shown - i guess forced off the side of the
bar.  can objects follow the chevron on a toolbar???
Taking QA Contact
QA Contact: asa → bugzilla
> but unlike a flex, if the bookmarks take up all
> the space, the following object isn't shown - i guess forced off the side of the
> bar.  can objects follow the chevron on a toolbar???

That sounds like bug 174390.

*** This bug has been marked as a duplicate of 174390 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
This does _not_ sound like a duplicate of bug 174390.

When I referred to bug 174390 in comment 8, I was specifically talking about the
last paragraph of comment 6 (which miahz even said was _another_ possible bug,
not this bug).

bug 178884 (this bug) should be REOPENED.

David
Sorry, I was probably a bit premature.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(In reply to comment #4)
> i've posted a capture of what it looks like in the mozillazine forum:
> http://www.mozillazine.org/forums/viewtopic.php?p=53520#53520

I get the same shaking as in that animated gif, when viewing this image:
http://prad.de/new/images/monitore/schlieren.jpg
with FireFox 0.9.3, default theme, bookmarks toolbar on the same row as the
menu, and browser window resized such that the image is automatically downsized
by FireFox.

Shaking stops when bookmarks toolbar is off.
Shaking only occurs with this particular image.
Zooming the image (left click) is impossible, because it gets immediately reset
to the downsized version.
Assignee: hyatt → bugs
Status: REOPENED → NEW
probable dupage:
bug 247032 - with animated screenshot attached
bug 243779

From the bugs and threads i've seen, there seems to be at least 2 varations. 
The "bookmarks on the menu bar" one as reported in this bug, which i've
personally experienced; and an apparently more random one that happens on
certain pages.

And just to update, i have seen this in 1.0PR when i was messing with the
bookmarks chevron with DOMI.  So it may not occur "naturally," but the
underlying bug is still there.

I thought i had documented it before, but i couldn't find the comment or thread,
so just for reference:
A while ago, while dissecting the bookmarks toolbar in my theme, i narrowed the
cause down to having any vertical margins on the overflow items of the bookmarks
items stack.  The overflow items layer is what contains the chevron.
Just did some quick tests.  The amount of vertical margin is directly
proportional to the height of the "bouncing."

Some rough test case steps (need DOMI):
A1. Add any amount of vertical (top and/or bottom) margin to the overflow items
(toolbaritem#personal-bookmarks/stack#bookmarks-stack/hbox.bookmarks-toolbar-overflow-items)

B1. Add any amount of vertical margin to the bookmarks chevron
(toolbaritem#personal-bookmarks/stack#bookmarks-stack/hbox.bookmarks-toolbar-overflow-items/toolbarbutton#bookmarks-chevron)

C1. Set a height (something larger than the toolbar would be, 50px, for example)
on the overflow padder
(toolbaritem#personal-bookmarks/stack#bookmarks-stack/hbox.bookmarks-toolbar-overflow-items/hbox#overflow-padder),
the overflow items layer, or any or its parents up to the toolbar
(#toolbar-menubar).
C2. Set a max-height on the chevron that is less than the height in step C1
(maybe 20px) - creating "implied" margins.
Assignee: bugs → nobody
QA Contact: bugzilla → toolbars
Duplicate of this bug: 221604
Duplicate of this bug: 252945
Duplicate of this bug: 268872
No longer blocks: 247116
To keep this (or some related, you tell me) issue alive: the bug described in https://bugzilla.mozilla.org/show_bug.cgi?id=247116#c88 is still present in build "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/2008012900 Iceweasel/2.0.0.12 (Debian-2.0.0.12-0etch1)". To quote:

  This is happening to me on Linux, too, when I drag the bookmarks toolbar items
  from the actual bookmarks toolbar to the top menu bar, right of the help menu,
  and then shrink the Firefox window so that it is so small that no bookmarks
  actually show up. When I enlarge it again so that at least one bookmark shows
  up, the bouncing stops.

While http://support.mozilla.com/kb/Window+shakes states it's fixed in 2.0.0.4, looks like it partly remained in 2.0.0.12, unfortunately.
OS: Linux → All
Hardware: x86 → All
We've since refactored this code multiple times (see e.g. bug 382466).
Status: NEW → RESOLVED
Closed: 16 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.