Closed Bug 1789007 Opened 2 years ago Closed 2 years ago

[foxfooding] Recently closed section from Firefox View should not list identical tabs if more than 1 was closed

Categories

(Firefox :: Firefox View, defect, P4)

Firefox 106
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox106 --- affected

People

(Reporter: pdehaan, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fidefe-2022-mr1-firefox-view] [foxfooding])

Firefox Version: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:104.0) Gecko/20100101 Firefox/104.0
Window Size (inner width and height): 1536x739
GitHub Username: @emelipasini

Steps to Reproduce

Open different random tabs to see the Recently closed section from Firefox View

Expected Behavior

I was hoping that the repeated pages would not be shown 2 times and also that new tab will not be shown on recently closed pages

Actual Behavior

The actual result was that repeated pages were displayed and also new tabs were shown twice. This happened because I closed repeated tabs and the new tab, not for a bug but I still think those two could be filter for a more clean view.

Attachment

Link to the original attachment

Whiteboard: foxfooding
Severity: -- → S3
Priority: -- → P3
Blocks: firefox-view
Summary: [foxfooding] Recently closed section from Firefox View can improve → [foxfooding] Recently closed section from Firefox View should not list identical tabs if more than 1 was closed
Whiteboard: foxfooding → [fidefe-2022-mr1-firefox-view] [foxfooding]

From sessionstore's perspective, tabs aren't necessarily identical just because they share the same URL. I'm skeptical that Firefox View should treat this any differently than the Recently Closed Tabs menu does.

Blocks: 1788692
No longer blocks: firefox-view
Flags: needinfo?(jhall)
Flags: needinfo?(jhall)
Flags: needinfo?(rfambro)

Sarah - Does 1796409 potentially address the concern in this bug for "identical URLs"? Also, I can't seem to reproduce the New Tab condition. Was that already addressed?

Flags: needinfo?(rfambro) → needinfo?(sclements)

(In reply to Ray Fambro from comment #2)

Sarah - Does 1796409 potentially address the concern in this bug for "identical URLs"? Also, I can't seem to reproduce the New Tab condition. Was that already addressed?

Bug 1796409 is specifically about duplicates in the Tab Pickup list. I do think Dão's comment makes sense in the context of how Session Store currently works across all surfaces that show Recently Closed Tabs. If we wanted to consider changing that behavior it might be a bigger conversation with UX and other engineers.

Users now have the ability to dismiss recently closed tabs, so this might be less of an issue. But if we remove duplicates of Synced Tabs, would users also expect to not see duplicates in Recently Closed tabs? Perhaps.

Regarding the new tab not showing up recently closed tabs, It looks like it was fixed but I can't find the bug atm.

Flags: needinfo?(sclements)

(In reply to Sarah Clements [:sclements] from comment #3)

Regarding the new tab not showing up recently closed tabs, It looks like it was fixed but I can't find the bug atm.

Empty tabs don't show up, but the new tab page can show up if it's not empty. To see examples of both cases:

  1. open a new tab, and close it immediately. Check recently closed tabs - it won't show up.
  2. open a new tab, type something in the URL bar, and then close it. It does show up.
  3. open a new tab, navigate to example.com in that new tab, then press the back button (to go back to the new tab page). Then close it. It does show up (as "new tab", because that was the loaded page and title at the time).

I think if we want to make changes to how we assess whether a new tab is "worth" saving in session restore / recently closed tabs, that's interesting but it'd probably be better to keep this bug focused on the "duplicate" issue. IIRC there was a separate issue on file about the new tab case that we closed as wontfix because of the above, though of course in principle we could reconsider that - but best not done in this bug, IMHO.

I think the crux of the "duplicate" issue is what Dão already highlighted in comment #1: session store actually has a lot of information about tabs, and we present only a small subset: an icon, title, domain name (not the full URL, though that's in the tooltip...) and the time it was closed. The recently closed tabs menu shows even less information^1. But the restored tab preserves the back/forward history (ie the current URL might be the same but one tab might have other pages in its history, whereas a second tab may not, or may have different pages!), scroll positions, form history, the url bar content, etc. But the minimal UI means that tabs that aren't "really" duplicates (because they differ in some of these respects) look like duplicates.

I'm not sure what the solution is to that issue - it's probably a bit of a UX question. I'm not sure how important it is, either, which is why we originally filed it under "future" rather than "immediate next steps" for FxView.

^1 The menus show only a title and icon. The URL is in the tooltip, but the native macOS menu doesn't show the tooltip, only Windows/Linux do - or you can look at the same menu in the hamburger menu, where the tooltip does show up because we control that panel (we don't control the macOS native menubar in the same way).

Ray, what do you want to do about this bug?

Flags: needinfo?(rfambro)

Thanks for all of the context! Let's delineate two different issues here: 1) addressing perceived duplicate urls and, 2) the New Tab page.

For this particular bug, let's just focus on the duplicate url issue. Due to the nuances present in how session store works, I think it makes sense to leave this working as it currently does. This could be something that we decide to reconsider in the future w/ the input of UX, but for now, I feel that we've mitigated this concern somewhat with the introduction of the dismiss function in the Recently Closed list.

Flags: needinfo?(rfambro)
Priority: P3 → P4
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.