xbl test3 doesn't render anything

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
16 years ago
6 years ago

People

(Reporter: blizzard, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Would anyone expect for this to work?  It's not displaying anything for me and
in my debug build it's generating all kinds of errors:

###!!! ASSERTION: frame state bit was set but frame has no view: 'value != 0',
file ../../../../../mozilla/layout/html/base/src/nsFrame.cpp, line 2262
Break: at file ../../../../../mozilla/layout/html/base/src/nsFrame.cpp, line 2262
Looks like the parser has stripped out all the bogus tags in there...
Assignee: other → harishd
Component: Layout → Parser
Keywords: regression
QA Contact: ian → moied
Doron, is the test supposed to work?

Boris, you marked this is a regression. When did this regress?

Comment 3

15 years ago
It doesn't work in 1.0 for me as well.
Hmm.. So I don't know what I meant in comment 1... At this point, I'd guess that
"extends" is just more or less broken in all sorts of cases due to
IsContentOfType checking, so the page's attempt to extend XUL elements fails...

If nothing else, I bet NotifyListBoxBody() would fail for this page....
Assignee: harishd → nobody
Component: HTML: Parser → Layout
QA Contact: moied → core.layout
(Assignee)

Comment 5

14 years ago
There are only three things wrong with this page:
1. The colours are all messed up - the original was white on black.
2. The LEAVES doesn't have the display: -moz-popup; style
3. XBL changed inherits to require the xbl: prefix
(Assignee)

Comment 6

14 years ago
http://nrr.dnsalias.net/test3/test.html shows the changes in action.
Neil, want to just fix the test page with your changes?

Updated

14 years ago
Assignee: nobody → neil.parkwaycc.co.uk

Comment 8

14 years ago
I've applied Neil's changes to the files on mozilla.org
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Component: Layout → webmaster@mozilla.org
OS: Linux → All
Product: Browser → mozilla.org
Hardware: PC → All
Resolution: --- → FIXED
Version: Trunk → other
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.