"porn surfing" messes up display

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Sven Schwarz, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I hope noone is offended by that summary, but it accurately describes how and
when this bug happens:
Open several tabs with pages containing lots of thumbnails linking directly to
jpg images. Jump between the tabs, load images, hit back etc. This works fine
for a couple of minutes, but after a while, Phoenix will no longer redraw the
entire window when hitting "back" or changing between tabs - the browser window
will now display a garbled mess of various recently displayed pages. 
Forcing a redraw (by minimizing/maximizing the window, or by dragging it over
the screen edge and back) works for a while, but after you do that a couple of
times, the complete browser window (toolbars, menus, window borders) will turn
to garbage.
This only seems to happen when directly displaying jpg files, images embedded in
 HTML work fine.
This also never happens when browsing with only one tab - there have to be
several tabs open at the same time.

Comment 1

15 years ago
As much as I hate to admit this, I've seen this behavior too. However, I've seen
it in Mozilla too, so this is not a Phoenix specific bug.

But the steps to reproduce is something like this:

1. Go to a page with links to lots (>30) of jpeg images.
2. Ctrl click on each link to open them in background tabs.
3. View the images, browse around, close them again.
Repeat step 1 to 3 a few times. 

Actual results:

The chrome starts to freak out, with black blocks instead of toolbar buttons,
and eventually, the browser becomes totally useless and you're forced to shut it
down. My guess is that this is some kind of a memory leak, since it only happens
after you've viewed a lot of images. Of course, what I was viewing was pictures
of different kinds of clouds, since I'm interested in meteorology. ;-)
Component: General → Browser-General
OS: Windows 2000 → All
Product: Phoenix → Browser
Version: unspecified → other

Comment 2

15 years ago
That's not the way to browse picture galleries. Put the following bookmarklet in
your personal toolbar while this bug is pondered upon (call it i+ or something):

javascript:(function(){ var e,s; IB=1; function isDigit(c) { return ("0" <= c &&
c <= "9") } L = location.href; LL = L.length; for (e=LL-1; e>=0; --e) if
(isDigit(L.charAt(e))) { for(s=e-1; s>=0; --s) if (!isDigit(L.charAt(s))) break;
break; } ++s; if (e<0) return; oldNum = L.substring(s,e+1); newNum = "" +
(parseInt(oldNum,10) + IB); while (newNum.length < oldNum.length) newNum = "0" +
newNum; location.href = L.substring(0,s) + newNum + L.slice(e+1); })();

Comment 3

15 years ago
Niklas, while that bookmarklet is useful, it's not really relevant to this bug.

I've seen this too (2002102504/WinXP).

David: bug 174760 is a fairly hefty memory leak involving large jpg images. 
Lots of big jpgs being loaded at once sounds a REALLY good way to trigger it.

Comment 4

15 years ago
Bug 174760 could be related, but the only thing that happened here when trying
to reproduce that bug was a heavy increase of virtual memory. The chrome was not
affected. I am not sure this is a dupe.

Comment 5

15 years ago
well the other bug went away - can anyone still reproduce this one in a recent
build of mozilla?
(Reporter)

Comment 6

15 years ago
I don't know if the Mozilla fixes for the bugs mentioned above are already
incorporated into the Phoenix code, but I have to say that the latest nightly
build of Phoenix (20023012) still exhibits this behavior - the only thing I
noticed is that it took much longer for things to go wrong. At a rough guess,
I'd say I viewed maybe 10MB of JPEGs before the chrome corrupted, with earlier
builds,  that would already happen after about 2MB of images.
By the way, I was able to reproduce this behavior with Mozilla (Release 1.2,
haven't tested any later versions), but it took much, much longer to appear -
apparently, there are some differences in memory handling when displaying JPEGs
between Mozilla and Phoenix. 

Comment 7

15 years ago
Reporter: Can you reproduce this bug with a recent build of Mozilla (for
example, 1.4rc3)? 

If so, then please comment again with details. 
If not, then please resolve this bug as WORKSFORME. Thanks.
(Reporter)

Comment 8

15 years ago
Problem seems to be gone now in Firebird (latest nightly)...haven't tried
Mozilla in a while.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.