If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[CRASH] MailNews crashes on startup

VERIFIED DUPLICATE of bug 17890

Status

SeaMonkey
MailNews: Message Display
P3
blocker
VERIFIED DUPLICATE of bug 17890
18 years ago
13 years ago

People

(Reporter: kinmoz, Assigned: Phil Peterson)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This is probably related to bug #17882.

If I migrate a 4.x profile and try to start mailnews, I crash with the stack
trace below.

The problem seems to be that the server entries in the prefs.js for my News
servers like news.mozilla.org are missing a username entry. Adding something
like:

    user_pref("mail.server.server3.userName", "kin");

for each news server fixes things.

nsUnescapeCount(char * 0x00000000) line 145 + 3 bytes
nsUnescape(char * 0x00000000) line 134 + 9 bytes
nsMsgFolder::Init(nsMsgFolder * const 0x027f0cc0, const char * 0x027f0de0) line
158 + 16 bytes
RDFServiceImpl::GetResource(RDFServiceImpl * const 0x010cc2a0, const char *
0x027f0de0, nsIRDFResource * * 0x0012d44c) line 662 + 16 bytes
nsMsgIncomingServer::CreateRootFolder() line 198 + 46 bytes
nsMsgIncomingServer::GetRootFolder(nsMsgIncomingServer * const 0x027efb90,
nsIFolder * * 0x0012d4f4) line 104 + 8 bytes
nsMsgAccountManagerDataSource::createServerResources(nsISupports * 0x027efb90,
void * 0x0012d578) line 410 + 47 bytes
nsSupportsArray::EnumerateForwards(nsSupportsArray * const 0x027ee3f0, int
(nsISupports *, void *)* 0x019b2e20
nsMsgAccountManagerDataSource::createServerResources(nsISupports *, void *),
void * 0x0012d578) line 352 + 20 bytes
nsMsgAccountManagerDataSource::GetTargets(nsMsgAccountManagerDataSource * const
0x022e78d0, nsIRDFResource * 0x022e8c70, nsIRDFResource * 0x013e5a30, int 1,
nsISimpleEnumerator * * 0x027ee4dc) line 353
CompositeAssertionEnumeratorImpl::GetEnumerator(nsIRDFDataSource * 0x022e78d0,
nsISimpleEnumerator * * 0x027ee4dc) line 498 + 37 bytes
CompositeEnumeratorImpl::HasMoreElements(CompositeEnumeratorImpl * const
0x027ee4d0, int * 0x0012d690) line 220 + 22 bytes
RDFGenericBuilderImpl::CreateContainerContents(nsIContent * 0x023314b0,
nsIRDFResource * 0x022e8c70, int 0) line 2293 + 36 bytes
RDFGenericBuilderImpl::CreateContents(RDFGenericBuilderImpl * const 0x023336b0,
nsIContent * 0x023314b0) line 741 + 23 bytes
RDFGenericBuilderImpl::RebuildContainer(RDFGenericBuilderImpl * const
0x023336b0, nsIContent * 0x023314b0) line 902 + 16 bytes
nsXULDocument::RebuildWidgetItem(nsIContent * 0x023314b0) line 3726 + 22 bytes
nsXULDocument::AttributeChanged(nsXULDocument * const 0x020590c0, nsIContent *
0x023314b0, int 0, nsIAtom * 0x02063f10, int -1) line 1190
nsXULElement::SetAttribute(nsXULElement * const 0x023314b0, int 0, nsIAtom *
0x02063f10, const nsString & {...}, int 1) line 2139
nsXULElement::SetAttribute(nsXULElement * const 0x023314c0, const nsString &
{...}, const nsString & {...}) line 991 + 35 bytes
ElementSetAttribute(JSContext * 0x02065760, JSObject * 0x023920a0, unsigned int
2, long * 0x01292c58, long * 0x0012dec8) line 258 + 26 bytes
js_Invoke(JSContext * 0x02065760, unsigned int 2, unsigned int 0) line 672 + 26
bytes
js_Interpret(JSContext * 0x02065760, long * 0x0012e740) line 2247 + 15 bytes
js_Invoke(JSContext * 0x02065760, unsigned int 0, unsigned int 0) line 688 + 13
bytes
js_Interpret(JSContext * 0x02065760, long * 0x0012ef74) line 2247 + 15 bytes
js_Invoke(JSContext * 0x02065760, unsigned int 0, unsigned int 0) line 688 + 13
bytes
js_Interpret(JSContext * 0x02065760, long * 0x0012f7a8) line 2247 + 15 bytes
js_Invoke(JSContext * 0x02065760, unsigned int 1, unsigned int 2) line 688 + 13
bytes
js_InternalCall(JSContext * 0x02065760, JSObject * 0x01283840, long 19457744,
unsigned int 1, long * 0x0012f910, long * 0x0012f8c8) line 765 + 15 bytes
JS_CallFunction(JSContext * 0x02065760, JSObject * 0x01283840, JSFunction *
0x02295810, unsigned int 1, long * 0x0012f910, long * 0x0012f8c8) line 2707 + 32
bytes
nsJSContext::CallFunction(nsJSContext * const 0x020658d0, void * 0x01283840,
void * 0x02295810, unsigned int 1, void * 0x0012f910, int * 0x0012f90c) line 328
+ 33 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x027d4ae4) line 103 + 48 bytes
nsEventListenerManager::HandleEvent(nsIPresContext & {...}, nsEvent *
0x0012fc70, nsIDOMEvent * * 0x0012fb14, unsigned int 7, nsEventStatus &
nsEventStatus_eIgnore) line 990 + 21 bytes
GlobalWindowImpl::HandleDOMEvent(GlobalWindowImpl * const 0x02065934,
nsIPresContext & {...}, nsEvent * 0x0012fc70, nsIDOMEvent * * 0x0012fb14,
unsigned int 1, nsEventStatus & nsEventStatus_eIgnore) line 2963
nsWebShell::OnEndDocumentLoad(nsWebShell * const 0x0149fd14, nsIDocumentLoader *
0x0149e540, nsIChannel * 0x01e93eb0, unsigned int 0, nsIDocumentLoaderObserver *
0x0149fd14) line 3340 + 34 bytes
nsDocLoaderImpl::FireOnEndDocumentLoad(nsDocLoaderImpl * 0x0149e540, nsIChannel
* 0x01e93eb0, unsigned int 0) line 865
nsDocLoaderImpl::OnStopRequest(nsDocLoaderImpl * const 0x0149e544, nsIChannel *
0x00000000, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 746
nsLoadGroup::SubGroupIsEmpty(unsigned int 0) line 118 + 46 bytes
nsLoadGroup::RemoveChannel(nsLoadGroup * const 0x02793cd0, nsIChannel *
0x02795a70, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 602
nsInputStreamChannel::OnStopRequest(nsInputStreamChannel * const 0x02795a74,
nsIChannel * 0x02795910, nsISupports * 0x00000000, unsigned int 0, const
unsigned short * 0x00000000) line 302
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x027955d0) line
322
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x027978b0) line 169 + 12 bytes
PL_HandleEvent(PLEvent * 0x027978b0) line 537 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x010819e0) line 498 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x0198019a, unsigned int 49497, unsigned int 0,
long 17308128) line 972 + 9 bytes
USER32! 77e71820()
010819e0()

Updated

18 years ago
Severity: normal → blocker

Comment 1

18 years ago
Same as http://bugzilla.mozilla.org/show_bug.cgi?id=17890

Comment 2

18 years ago
Windows 98 stack trace / Dr Watson log is at http://schist/17890.txt
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Comment 3

18 years ago
*** This bug has been marked as a duplicate of 17890 ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.