Closed Bug 1789356 Opened 2 years ago Closed 2 years ago

Fetch header only not working if TOP capability not advertized by the server

Categories

(MailNews Core :: Networking: POP, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr102 fixed, thunderbird105 fixed)

RESOLVED FIXED
106 Branch
Tracking Status
thunderbird_esr102 --- fixed
thunderbird105 --- fixed

People

(Reporter: alaninfo, Assigned: rnons)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files)

Attached image TB header fault.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:104.0) Gecko/20100101 Firefox/104.0

Steps to reproduce:

Untick Fetch header only
close Thunderbird then open again
Tick Fetch header only
close Thunderbird then open again
Send myself test emails from another email address.

Actual results:

Still getting full email
Currently on V102.2.1

Expected results:

Just the header for message

Thanks for reporting, can you get some logs by following bug 1783290 comment 3

As requested  Error Console Log during message download from server  ....

As requested Error Console Log during message download from server ....

1662506982559 addons.xpi WARN Checking C:\Program Files\Mozilla Thunderbird\distribution\extensions for addons
mailnews.pop3.0: C: STAT Pop3Client.jsm:451:20
mailnews.pop3.0: S: +OK 0 0

Pop3Client.jsm:309:18
mailnews.pop3.0: Done with status=0 Pop3Client.jsm:1310:18
mailnews.pop3.0: C: QUIT Pop3Client.jsm:451:20
mailnews.pop3.0: Connection closed. Pop3Client.jsm:343:18
mailnews.pop3.0: S: +OK

Pop3Client.jsm:309:18
This page is in Quirks Mode. Page layout may be impacted. For Standards Mode use “<!DOCTYPE html>”.
blank
window.controllers/Controllers is deprecated. Do not use it for UA detection. blank
This page is in Quirks Mode. Page layout may be impacted. For Standards Mode use “<!DOCTYPE html>”.
blank
This page is in Quirks Mode. Page layout may be impacted. For Standards Mode use “<!DOCTYPE html>”.
MsgComposeCommands.js:10508:14
This page is in Quirks Mode. Page layout may be impacted. For Standards Mode use “<!DOCTYPE html>”.
4 MsgComposeCommands.js:3972:28
This page is in Quirks Mode. Page layout may be impacted. For Standards Mode use “<!DOCTYPE html>”.
MimeMessageUtils.jsm:148:23
mailnews.pop3.1: Connecting to pop://pop3.tpg.com.au:110 Pop3Client.jsm:132:18
mailnews.pop3.1: Connected Pop3Client.jsm:268:18
mailnews.pop3.1: S: +OK POP3 Ready rpt-glb-mail03 00021663

Pop3Client.jsm:309:18
mailnews.pop3.1: C: CAPA Pop3Client.jsm:451:20
mailnews.pop3.1: S: +OK Capability list follows, mate

STLS

Pop3Client.jsm:309:18
mailnews.pop3.1: S: UIDL

Pop3Client.jsm:309:18
mailnews.pop3.1: S: USER

.

Pop3Client.jsm:309:18
mailnews.pop3.1: C: STLS Pop3Client.jsm:451:20
mailnews.pop3.1: S: +OK Begin TLS negotiation now.

Pop3Client.jsm:309:18
mailnews.pop3.1: C: CAPA Pop3Client.jsm:451:20
mailnews.pop3.1: S: +OK Capability list follows, mate

Pop3Client.jsm:309:18
mailnews.pop3.1: S: UIDL

Pop3Client.jsm:309:18
mailnews.pop3.1: S: USER

.

Pop3Client.jsm:309:18
mailnews.pop3.1: Possible auth methods: USERPASS Pop3Client.jsm:521:18
mailnews.pop3.1: Current auth method: USERPASS Pop3Client.jsm:597:18
mailnews.pop3.1: C: USER alaninfo Pop3Client.jsm:451:20
mailnews.pop3.1: S: +OK USER alaninfo set, mate

Pop3Client.jsm:309:18
mailnews.pop3.1: C: Logging suppressed (it probably contained auth information) Pop3Client.jsm:445:20
mailnews.pop3.1: S: +OK Mailbox locked and ready SESSIONID=<spool-host16-25040-1662507768-1>

Pop3Client.jsm:309:18
mailnews.pop3.1: C: STAT Pop3Client.jsm:451:20
mailnews.pop3.1: S: +OK 1 1714

Pop3Client.jsm:309:18
mailnews.pop3.1: Folder lock acquired uri=mailbox://alaninfo@pop3.tpg.com.au/Inbox. Pop3Client.jsm:910:22
mailnews.pop3.1: C: LIST Pop3Client.jsm:451:20
mailnews.pop3.1: S: +OK scan listing follows

1 1714

.

Pop3Client.jsm:309:18
mailnews.pop3.1: C: UIDL Pop3Client.jsm:451:20
mailnews.pop3.1: S: +OK unique-id listing follows

1 1202513868.5474

.

Pop3Client.jsm:309:18
mailnews.pop3.1: C: RETR 1 Pop3Client.jsm:451:20
mailnews.pop3.1: S: +OK Message follows

Return-Path: <trimsails@tpg.com.au>

Received: from deliver ([unix socket])

 by spool-host16.tpgi.com.au (Cyrus v2.4.13) with LMTPA;

 Wed, 07 Sep 2022 09:41:46 +1000

X-TPG-Junk-Checked: Yes

X-TPG-Junk-Status: Message not scanned because user authenticated using SMTP AUTH

X-TPG-Abuse: host=[124.168.231.117]; ip=124.168.231.117; date=Wed, 7 Sep 2022 09:41:46 +1000; auth=kUdPCGsBRWiEhUYgrKEBNKXBNCwnci+kno6fS6yG0wQ=

DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=tpg.com.au; s=alpha;

t=1662507706; bh=39q3lJqxquD3GDYxnAh66zUKYcP5MuPwm9yjWy897Lc=;

h=X-TPG-Abuse:Message-ID:Date:MIME-Version:To:From:Subject:

 Content-Type;

b=eEC9Xtq2jP3lGXd0Td7TrvdW2AAzyhINMU1Eon5Geofp89UwShmCDru51jXAu5B9h

 EpMXTSFtBCInIt4VUjNWS+GZhG4gisPLHUM5nUxn3BriD/v8fveVvm7AWxX8vq+d9i

 Zz3PdZcNd25h0xyLA0TkfuOxAhzpPednENOtoC1M=

Received: from [192.168.1.103] (124-168-231-117.tpgi.com.au [124.168.231.117] (may be forged))

(authenticated bits=0)

by rpt-cro-mail03.tpgi.com.au (envelope-from trimsails@tpg.com.au) (8.14.3/8.14.3) with ESMTP id 286Nf6iU028646

for <alaninfo@tpg.com.au>; Wed, 7 Sep 2022 09:41:46 +1000

Message-ID: <1cebf7a3-0804-d7c1-63c4-fc390996ebce@tpg.com.au>

Date: Wed, 7 Sep 2022 09:41:03 +1000

MIME-Version: 1.0

User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:102.0) Gecko/20100101

Thunderbird/102.2.1

Content-Language: en-AU

To: "'Al'" <alaninfo@tpg.com.au>

From: "Alan.K" <trimsails@tpg.com.au>

Subject: TEST MESSAGE

Content-Type: text/plain; charset=UTF-8; format=flowed

Content-Transfer-Encoding: 8bit

TEST MESSAGE

   TEST MESSAGE

      TEST MESSAGE

         TEST MESSAGE

            TEST MESSAGE

.

Pop3Client.jsm:309:18
mailnews.pop3.1: C: DELE 1 Pop3Client.jsm:451:20
mailnews.pop3.1: S: +OK message deleted

Pop3Client.jsm:309:18
mailnews.pop3.1: Folder lock released. Pop3Client.jsm:1114:20
mailnews.pop3.1: Done with status=0 Pop3Client.jsm:1310:18
mailnews.pop3.1: C: QUIT Pop3Client.jsm:451:20
This page is in Quirks Mode. Page layout may be impacted. For Standards Mode use “<!DOCTYPE html>”.
2 blank
mailnews.pop3.1: Connection closed. Pop3Client.jsm:343:18
mailnews.pop3.1: S: +OK

Pop3Client.jsm:309:18

OK, your server doesn't advertise TOP capability, which we use to fetch headers only. Seems the old code will send TOP anyway and see if it works.

It's sad CAPA can't be trusted for many POP3 servers. Will make a fix.

Summary: Pop server - Fetch header only not working - reported in V102.1 and as FIXED in V102.2.0 but did not working for me - V102.2.1 loaded and still not working. → Fetch header only not working if TOP capability not advertized by the server
Status: UNCONFIRMED → NEW
Component: Untriaged → Networking: POP
Ever confirmed: true
Product: Thunderbird → MailNews Core
Assignee: nobody → remotenonsense
Status: NEW → ASSIGNED
Regressed by: pop3-js
Target Milestone: --- → 106 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/a47e8e192f76
Try TOP even if not advertised by the server in Pop3Client. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

Comment on attachment 9293460 [details]
Bug 1789356 - Try TOP even if not advertised by the server in Pop3Client. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug pop3-js
User impact if declined: Fetch headers only doesn't work if TOP capability not advertised by the server.
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9293460 - Flags: approval-comm-beta?

Comment on attachment 9293460 [details]
Bug 1789356 - Try TOP even if not advertised by the server in Pop3Client. r=mkmelin

[Triage Comment]
Approved for beta

Attachment #9293460 - Flags: approval-comm-beta? → approval-comm-beta+

[Triage Comment]
Approved by wsmwk via Matrix.
Patch modified for comm-esr102; tests verified passing with local build.

Attachment #9294722 - Flags: approval-comm-esr102+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: