Closed Bug 1789644 Opened 3 months ago Closed 2 months ago

[Quickactions] Actions should be visible when using `>`, even if "Quick actions" is not enabled in preferences

Categories

(Firefox :: Address Bar, defect)

defect

Tracking

()

VERIFIED FIXED
107 Branch
Tracking Status
firefox107 --- verified

People

(Reporter: glob, Assigned: aminomancer)

References

Details

Attachments

(2 files)

STR

  1. Disable Quick actions via Preferences --> Address Bar
  2. Confirm that actions are no longer visible in the address bar's dropdown
  3. Type > to start searching for actions

Expected

  • address bar switched to searching for actions
  • a filtered list of available actions

Actual

  • address bar switched to searching for actions
  • no actions are listed

Notes

  • browser.urlbar.suggest.quickactions is false
  • browser.urlbar.shortcuts.quickactions is true
Attached image A lack of action
Summary: [Quickactions] Actions use be visible when using `>`, even if "Quick actions" is not enabled in preferences → [Quickactions] Actions should be visible when using `>`, even if "Quick actions" is not enabled in preferences

Some notes: If we add a new pref browser.urlbar.quickactions.enabled, that can enable/disable the entire feature, while browser.urlbar.suggest.quickactions will only determine whether quick action results are shown outside of the quick actions search mode.

browser.urlbar.shortcuts.quickactions and browser.urlbar.quickactions.showPrefs would remain unchanged, determining the display of the quick actions one-off search engine button and the checkbox in about:preferences, respectively.

The relevant code is here - we can change it to this:

isActive(queryContext) {
  return (
    lazy.UrlbarPrefs.get("quickactions.enabled") &&
    ((lazy.UrlbarPrefs.get("suggest.quickactions") && !queryContext.searchMode) ||
      queryContext.searchMode.source == UrlbarUtils.RESULT_SOURCE.ACTIONS)
  );
}

Change the behavior of the QuickActions provider, so that setting the
pref quickactions.enabled to false will prevent showing quick action
results in all contexts, while setting suggest.quickactions to false
will only prevent showing quick action results in the default search
mode (i.e., quick action results will still appear in the Quick Actions
search mode enabled by typing > in the urlbar).

Assignee: nobody → shughes
Status: NEW → ASSIGNED
Pushed by shughes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/50f72898d7b8
Add a pref toggle for QuickActions, separate from the pref for suggestions. r=mak,daleharvey
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch

The issue is verified fixed using the latest Fx107.0a1 on Windows 10 and Ubuntu 22.04. The buttons are correctly shown in searchmode with the suggestions disabled.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.