Closed Bug 1789789 Opened 2 years ago Closed 3 months ago

Firefox not supported on t-mobile.com in Private mode

Categories

(Firefox :: Private Browsing, defect, P3)

Firefox 106
Desktop
Windows 10
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox106 --- affected

People

(Reporter: ctanase, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

Attached image FF private not supp.png

Environment:
Operating system: Windows 10
Firefox version: Nightly 106.0a1 (2022-09-07)

Preconditions:
• Private window opened

Steps to reproduce:

  1. Go to https://www.t-mobile.com/signin
  2. Observe the behaviour.

Expected Behaviour:
The page is supported in private mode.

Actual Behaviour:
The page is not supported in private mode.

Notes:

  1. Screenshot provided
  2. Reproducible regardless of the ETP status
  3. Reproducible on Firefox Release
  4. Not reproducible on Chrome incognito mode

This is not a tracking protection issue. It looks to me that the t-mobile page runs a feature detection script to figure out if it's in a private window to show the unsupported page.

No longer blocks: tp-breakage
Severity: -- → S3
Component: Privacy: Anti-Tracking → Private Browsing
Product: Core → Firefox
Blocks: 1366318

People say that using Hide Private Mode extension fixes t-mobile site. That extension fakes existence of IndexDB APIs in Private Browsing Mode.

This seems to be the check:

  function Og(a) {
    try {
      window.localStorage ? (window.localStorage.setItem('qmtest', '1'), window.localStorage.removeItem('qmtest')) : Mg(a)
    } catch (c) {
      Mg(a)
    }
    try {
      var b = a.pe.bind(a);
      if (window.webkitRequestFileSystem) webkitRequestFileSystem(0, 0, function () {
      }, b);
       else if ('MozAppearance' in document.documentElement.style) window.indexedDB.open('test').onerror = function (c) {
        a.pe();
        c.preventDefault()
      };
       else if (/constructor/i.test(window.HTMLElement) || window.safari) try {
        0 < window.localStorage.length && (window.localStorage.setItem('qmtest', '1'), window.localStorage.removeItem('qmtest')),
        window.openDatabase('', '', '', 0)
      } catch (c) {
        a.pe()
      } else window.indexedDB || !window.PointerEvent && !window.MSPointerEvent || a.pe()
    } catch (c) {
    }
  }

If they don't actually need indexedDB and are just blocking private browsing mode intentionally then they're likely to update this code if we shim it. So It may be best to reach out and confirm why they're blocking private browsing modes.

Tested with Firefox Nightly 125.0a1. Page now loads as expected in PBM.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: