If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

There is no Security under EDIT->Mail & Newsgroup Account Settings->(Profile)

VERIFIED WORKSFORME

Status

MailNews Core
Security: S/MIME
--
major
VERIFIED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Conrad Thompson, Assigned: Stephane Saux)

Tracking

Other Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

When attempting to setup security in mail and newsgroups (Add Mail Cert) there
is no security option under the account settings (See Help for setting up
certificates)

Reproducible: Always

Steps to Reproduce:
1. Open a new mail message
2. Click on Edit
3. Click on Mail & Newsgroup Account Settings
4. Look under the mail account you are attempting to add the certificate to

Actual Results:  
There is no security option for adding certificates that have been installed.

Expected Results:  
Opened up a dialog to allow me to choose what certificate I wanted to use with
that mail account
-> PSM (security:General is for security holes but not for encryption. Please
read the component descvription)

Please read bug 176775
Do you see this if you install 1.2b in a empty directory ?
(uninstall, delete all files that are left in c:\program..\Mozilla..., reinstall)
Assignee: mstoltz → ssaux
Component: Security: General → S/MIME
Product: MailNews → PSM
QA Contact: junruh → carosendahl
Version: other → unspecified
(Reporter)

Comment 2

15 years ago
This was a cleen install on a clean test box, the only thing a little weird is I
am using a post Windows 2k SP3 security patch for the stock cert controls in 2k.
I will install on a stock sp3 box and test... BTW I did search the bugs before
posting and did not find the other one...
(Reporter)

Comment 3

15 years ago
Well I think that was it.. Installed on clean system with only stock SP3 and it
worked just fine... I uninstalled and reinstalled on Test system with post sp3
fix and still had the issue so I am also going to list with Microsoft but I am
not sure where the two would interact as the sub systems do not interact as far
as I an see.
uninstall doesn't help.
You must manually remove not by the uninstaller deleted files !
You could also try a new profile (run "mozilla -profilemanager" to create an
additional test profile)

I don't think that this patch will afffect mozilla in this way...
(Reporter)

Comment 5

15 years ago
New Profile solved the issue... Guess it's not a bug after all :( Thanks....
You can try to repeair you old profile :
delete 
Profile\Chrome\*.* (you will loose all additional installed language and Themes)
Profile\Xul.mfl
Profile\localstore.rdf
profile\key3.db
profile\cert7.db (you wil loose all installed certificates)

-> wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 7

15 years ago
Verified - comment #6 or reinstallation is the only way to repair this. 
Unfortunately, this is a complex issue not easily fixed as it occurs during
installation and has several other factors involved.  In effect, while yes it
might occur, it does so randomly.
Status: RESOLVED → VERIFIED

Comment 8

15 years ago
*** Bug 179386 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Component: Security: S/MIME → Security: S/MIME
Product: PSM → Core

Updated

9 years ago
Component: Security: S/MIME → Security: S/MIME
Product: Core → MailNews Core
QA Contact: carosendahl → s.mime
You need to log in before you can comment on or make changes to this bug.