Closed Bug 178991 Opened 18 years ago Closed 14 years ago

BiDi: Unclickable links if near neutral characters e.g. parentheses, bullets

Categories

(Core :: Layout: Text and Fonts, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: neokuwait, Assigned: smontagu)

References

()

Details

(Keywords: rtl, top100)

Attachments

(2 files)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021101
  
Both World/Arabic and World/Hebrew are effected by this bug. 

This is mouse related, as it doesn't apply if using the Keyboard for 
navigation (i.e. Tab then Enter works fine)


1. Visit http://dmoz.org/World/Arabic/
2. Try clicking on a category (under the "Top: World: Arabic" line)

Actual Results: Links cannot be clicked and no hand cursor.
Expected Results: Normal links behavior.
Confirming and taking.
Assignee: mkaply → smontagu
Status: UNCONFIRMED → NEW
Ever confirmed: true
Same on linux platform; Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b)
Gecko/20030130

(I'm just glad that I was able to find this bug, preventing double dubmission.)
Attached file A slim testcase
I've just encountered this problem, and I thought a testcase would benefit the
bug description. This testcase has no Hebrew or Arabic text - the "direction:
rtl" is enough to screw up the clickability. Note the first (rightmost)
parenthesis points to link1, the rest of the line to link3.
dmoz is a top100 site, so adding keyword.
Keywords: top100
I don't see this behavior on latest builds.

You are welcome to reopen if you do see this again.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
Bug remains in effect, same as alqays, with build 2004-07-30-13. Will try Linux
later on. Please reopen.
Maybe i'm missing something:

Is there a linke on this page:
http://dmoz.org/World/Hebrew

or in the testcase tha isn't clickable for you?

(My UA: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040723
Firefox/0.9.1+)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
It seems the layout in dmoz.org has changed since this bug was first reported,
but the testcase exhibits the problem. My comment #3 remains in effect.
Ye... but it wasn't what i got from the bug summary, we need a better description.
Keywords: top100
Summary: BiDi: Unclickable links if near parenthesis (dmoz) → BiDi: Unclickable links if near parenthesis
Although dmoz changed layout, this bug is still perfectly reproducible with my
recent firefox build. 

Try clicking on the links below the Arabic categories (i.e. where it says
"Regional:Africa:Regions:North Africa" in english). If these links are clickable
to you than please mention your build date and mark this bug as worksforme. I'm
seeing this on linux too, by the way.

In any case, I think Eyal's testcase is more suitable to the somewhat related
Bug 197955. Considering the striking similarities to that bug, perhaps this
testcase was attached here by mistake?
Blocks: 197955
Blocks: 269759
Summary: BiDi: Unclickable links if near parenthesis → BiDi: Unclickable links if near neutral characters e.g. parentheses, bullets
*** Bug 197955 has been marked as a duplicate of this bug. ***
Adding a slimmer version of the testcase from the dupe. Note that:

- Bug manifests itself even though the paragraph is LTR
- The invalid link does not cover only the area of the other two links, but
also the area between them (artifically enlarged with  's	- the bug
remains in effect without them as well).
*** Bug 283668 has been marked as a duplicate of this bug. ***
*** Bug 300355 has been marked as a duplicate of this bug. ***
Depends on: 299065
No longer blocks: 269759
*** Bug 307697 has been marked as a duplicate of this bug. ***
*** Bug 307673 has been marked as a duplicate of this bug. ***
Hallo!

please see bug 179393 comment 11 and bug 179393 comment 12
bug 179393 images between two input fields are displayed in the wrong order
and the attachment there
https://bugzilla.mozilla.org/attachment.cgi?id=206193
title of the attachment:
screen dump relating to rendering of "non-textual entities" - difference between Firefox and IE

I would be happy to know any workaround and answers to the questions posted there.
Thanks for your support in advance.

best regards reinhardt [[user:gangleri]]
*** Bug 322040 has been marked as a duplicate of this bug. ***
Fixed by the fix for bug 299065.
Status: REOPENED → RESOLVED
Closed: 16 years ago14 years ago
Resolution: --- → FIXED
Duplicate of this bug: 371296
Duplicate of this bug: 388832
This bug is certainly NOT fixed. Just take a look at "A slim testcase" again. Please un-resolve this bug!
Ido, what version did you test with? This is fixed in nightly builds and the betas of Firefox 3. It is not fixed in any version of Firefox 2.
Keywords: rtl
Aha. My apologies then. I was thrown off by the date of the fix (2006-02).
Duplicate of this bug: 423112
Duplicate of this bug: 424948
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.