[REGRESSION][PP]FCC setting contains bogus data. Compose Window won't close after send

VERIFIED FIXED in M11

Status

defect
P3
major
VERIFIED FIXED
20 years ago
11 years ago

People

(Reporter: bugzilla, Assigned: bugzilla)

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Will check in soon the fix)

Since the new FCC preferences in Account manager, FCC prefs contains "..." if
user try to set it through account manager (even if it's turn off). Then every
time you send a message, You get the StringID Error Alert and the Compose Window
won't close. At this point, the user has not idea if the message has been sent
correctly or not.

Solution:

1) either write a patch that look for the "..." which comes from the select
widget or make the code looking for the FCC check box to be sure is on
(actually, this setting is ignored by the BackEnd)

2) change this stupid string ID alert and put an explicite human language text
instead.

I can do this today...
Status: NEW → ASSIGNED
Target Milestone: M11
QA Contact: lchiang → esther
Whiteboard: Get a Fix, waiting for review
Whiteboard: Get a Fix, waiting for review → Get a Fix and a review,waiting for approval
Whiteboard: Get a Fix and a review,waiting for approval → Will check in soon the fix
Fix reviewed by alecf and approved bychofmann
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I have fixed the following problems:

1) Now if FCC failed we get a nice alert telling you what appends and asking you
if you want the compose window back.

2) Will repect the FCC checkbox value in the account manager before FCC a
message except if the user as selected manually a FCC folder from the menu
Message/File Carbone Copy

NOTE: Mac/Unix users should not set FCC through the account manager because of
selection problem in the select widget which lead FCC to failed. Users need to
edit prefs manually!
Status: RESOLVED → VERIFIED
Using 1999110911 builds on win98, mac and linux this is fixed.  #1 gives a nice
alert when you have a bogus string in the Sent field.  #2 the copy check box
value is respected, when unchecked the mail is sent and no copy goes to a folder
b.) if user selects a FCC folder using menu, when the box is unchecked a copy
does go the menu specified folder
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.