Closed Bug 1790278 Opened 3 months ago Closed 1 month ago

Message Status Icon in Subject Columns Is Too Difficult to See in dark mode

Categories

(Thunderbird :: Theme, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr102+ affected)

RESOLVED FIXED
108 Branch
Tracking Status
thunderbird_esr102 + affected

People

(Reporter: bugzilla.mozilla.org, Assigned: micah)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:104.0) Gecko/20100101 Firefox/104.0

Steps to reproduce:

TB 102.2.2
Use dark theme
Reply to a message

Actual results:

The little message status icon to the left of the message subject is too difficult to see. The "Replied" icon is deep purple on a dark gray background

Expected results:

Something more easy to see

Also, it would be GREAT if this little icon were in it's own column, not part of the subject text. This way I could move it or remove it or set styles on it, etc

I added this following to my userChrome.css file and it makes things much better for me.
I copied it from the built-in css for the icons and modified it by changing the background and fill colors for only dark color scheme

/* ..... icons in subject column, dark color scheme ..... */
@media (prefers-color-scheme: dark) {
treechildren::-moz-tree-image(subjectCol) {
background: #101010 !important;
}

treechildren::-moz-tree-image(subjectCol, replied) {
fill: var(--color-purple-40) !important;
stroke: var(--color-purple-40) !important;
}

treechildren::-moz-tree-image(subjectCol, forwarded) {
fill: var(--color-blue-40) !important;
}

treechildren::-moz-tree-image(subjectCol, redirected) {
fill: var(--color-orange-40) !important;
}

treechildren::-moz-tree-image(subjectCol, replied, forwarded) {
fill: var(--color-blue-40) !important;
stroke: var(--color-purple-40) !important;
}

treechildren::-moz-tree-image(subjectCol, replied, redirected) {
fill: var(--color-orange-40) !important;
stroke: var(--color-purple-40) !important;
}

treechildren::-moz-tree-image(subjectCol, forwarded, redirected) {
fill: var(--color-blue-40) !important;
stroke: var(--color-orange-40) !important;
}

treechildren::-moz-tree-image(subjectCol, replied, forwarded, redirected) {
fill: var(--color-blue-40) !important;
stroke: var(--color-purple-40) !important;
}

treechildren::-moz-tree-image(subjectCol, new) {
fill: var(--color-yellow-40) !important; /* override the selected, focus rule /
stroke: var(--color-orange-40) !important; /
override the selected, focus rule */
}

treechildren::-moz-tree-image(subjectCol, selected, focus) {
fill: var(--select-focus-text-color) !important;
stroke: var(--select-focus-text-color) !important;
}
}

Component: Untriaged → Theme
Summary: Message Status Icon in Subject Columns Is Too Difficult to See → Message Status Icon in Subject Columns Is Too Difficult to See in dark mode
Duplicate of this bug: 1780408
Severity: -- → S4
Status: UNCONFIRMED → NEW
Ever confirmed: true

Micah, could you define better matching colours for the dark theme?

Flags: needinfo?(micah)
Assignee: nobody → micah
Status: NEW → ASSIGNED
Flags: needinfo?(micah)
Target Milestone: --- → 108 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/c2ac0848d0ac
style message status icons for dark color scheme. r=aleca,Paenglab

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.