Closed Bug 1790307 Opened 3 months ago Closed 3 months ago

Make preferences use modern flexbox emulation.

Categories

(Firefox :: Settings UI, task, P1)

task

Tracking

()

RESOLVED FIXED
107 Branch
Tracking Status
firefox107 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

(Blocks 1 open bug, Regressed 4 open bugs)

Details

Attachments

(2 files, 1 obsolete file)

No description provided.

Emulated flexbox doesn't support this, but allows you to specify widths
in percentages instead, so do that.

This shouldn't have any observable behavior change, but this is the
first page that uses modern flexbox layout instead of XUL layout.

In practice, this means that various interesting bugs that arise from
poor interaction between xul and block / flex / grid should disappear /
no longer be an issue for front-end developers.

Depends on D157073

This shouldn't have any observable behavior change, but this is the
first page that uses modern flexbox layout instead of XUL layout.

In practice, this means that various interesting bugs that arise from
poor interaction between xul and block / flex / grid should disappear /
no longer be an issue for front-end developers.

Note that this depends on bug 1790303.

Comment on attachment 9294176 [details]
Bug 1790307 - Use modern flexbox in about:addons. r=#extension-reviewers

Revision D157075 was moved to bug 1790308. Setting attachment 9294176 [details] to obsolete.

Attachment #9294176 - Attachment is obsolete: true
Severity: -- → N/A
Priority: -- → P1
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/646ae1f6d62c
Remove equalsize="always" usage from preferences. r=Gijs,preferences-reviewers
https://hg.mozilla.org/integration/autoland/rev/fd57a3ea2b88
Use modern flexbox in preferences. r=preferences-reviewers,Gijs
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 106 Branch
Regressions: 1790899
Regressions: 1790900
Regressions: 1790902
Regressions: 1790903
Regressions: 1790904

Emilio, I know you've put up patches for a bunch of the regressions but given soft freeze has now started, should we consider backing out the second patch here and relanding it after soft freeze to give ourselves some time to address any fallout, discovered or otherwise?

Flags: needinfo?(emilio)

Yeah. Most fixes are one-liners, not super-concerning, but that's fair.

We'd need to back out both patches tho, otherwise the applications menu would be broken (because width: 50% doesn't work on XUL)... Would it be reasonable to back both out from beta as soon as the merge happens? Alternatively I guess we can back them out today, and I can reland after the soft freeze, if you want.

Flags: needinfo?(emilio) → needinfo?(gijskruitbosch+bugs)

(In reply to Emilio Cobos Álvarez (:emilio) from comment #8)

Would it be reasonable to back both out from beta as soon as the merge happens? Alternatively I guess we can back them out today, and I can reland after the soft freeze, if you want.

I think backing out today and relanding on Monday/Tuesday is the easiest in that you don't need to request approval for anything (sheriffs will back you out on request), but I don't have a super strong preference either way.

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(emilio)

Backed out as per Emilio's request.

Backout link

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 106 Branch → ---

I asked sheriffs to back out, will re-land on monday after the freeze is over.

Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fa16221c24fe
Remove equalsize="always" usage from preferences. r=Gijs,preferences-reviewers
https://hg.mozilla.org/integration/autoland/rev/0bd09bf30151
Use modern flexbox in preferences. r=preferences-reviewers,Gijs
Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch
Regressions: 1792611
Regressions: 1792730
Regressions: 1792881
Regressions: 1793662
Regressions: 1794969
Regressions: 1794987
Regressions: 1795049
Regressions: 1796988
Regressions: 1800379
Regressions: 1792319
You need to log in before you can comment on or make changes to this bug.