Turning off "open unrequested windows" turns off prompt

VERIFIED DUPLICATE of bug 167559

Status

VERIFIED DUPLICATE of bug 167559
16 years ago
14 years ago

People

(Reporter: mturyn, Assigned: bugs)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The script below worked fine with Mozilla 1.1 when scripting preferences were
set such that unrequested windows wouldn't be opened by scripts.  Under 1.2b
(2002-10-16.12) not allowing unrequested opens also keeps the below from opening
the prompt.



<script language="JavaScript">
var def ="http://www.slashdot.com" ;
q=prompt("New
URI/search?:","http://www.slashdot.com","http://www.slashdot.com","http://www.slashdot.com");

if((""+q)!="null"){
    if ( q.indexOf(" ") != -1 ){
    // Search if there are spaces here:
       q='http://www.google.com/search?q='+escape(q); 
    } else if(q.indexOf("://") == -1 ){
	q = "http://" + q ;
    }
   location.href = q ;
} else {
   history.go(-1) ;
}


</script>
This will be fixed in 1.2final.

*** This bug has been marked as a duplicate of 167559 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.