Closed Bug 1791090 Opened 2 years ago Closed 2 years ago

[foxfooding] Desktop browser loads mobile site when using Tab pickup after browsing on phone

Categories

(Firefox :: Firefox View, defect)

Firefox 106
Desktop
Unspecified
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: pdehaan, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fidefe-2022-mr1-firefox-view] [foxfooding])

Attachments

(2 files)

Firefox Version: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/105.0.0.0 Safari/537.36
Window Size (inner width and height): 1030x919
GitHub Username: @lime124

Steps to Reproduce

On my iOS beta Firefox, was looking at a website. put the phone down. went to my laptop and refreshed Firefox view to get the latest tab.
happily clicked on it and was confused when the website loaded (that screenshot is in a full screen window on my MacBook). I couldn't understand why the webpage looked so blown up. I thought maybe it had trouble loading properly so I refreshed the page and it did the same. I then wondered if maybe the website loaded in mobile view. I checked the URL and guessed that the "M" meant mobile. I tried removing it and reloading and it did the trick.
tl;dr loading the mobile view on desktop was totally unexpected and completely broke the experience of the webpage which honestly really hurt the coolness of the feature. I knew how to fix, but most won't.
https://www.potterybarnkids.com/m/products/charlie-step-up-captains-bed/?pkey=ckids-beds

Expected Behavior

Not sure. It'd be difficult to identify URLs as mobile specific (note the /m/ path in the URL) and redirect those while on a desktop browser.

Actual Behavior

Loading the mobile view on desktop was totally unexpected and completely broke the experience of the webpage which honestly really hurt the coolness of the feature.

Attachment


Link to the original attachment

Whiteboard: [foxfooding] → [fidefe-2022-mr1-firefox-view] [foxfooding]
Blocks: firefox-view

A lot of sites use different URLs for their mobile vs. desktop versions. It might be m.example.com vs. www.example.com, or in this case it looks like the /m/ in the URL is how they know to deliver the mobile-ready page. Some sites might redirect or adapt when loaded in a desktop browser, others not.
Its an interesting problem that occurs across the modern usage of the web, but its not something we can realistically fix in Firefox View. It might be a good discussion to start on https://connect.mozilla.org - maybe Firefox could detect you've loaded what looks like a mobile version and if we are pretty sure we can load a desktop version offer an option to do that.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX

but its not something we can realistically fix in Firefox View. It might be a good discussion to start on https://connect.mozilla.org - maybe Firefox could detect you've loaded what looks like a mobile version and if we are pretty sure we can load a desktop version offer an option to do that.

Firefox and Focus for Android do something like this for requesting the desktop version of a website. Not for "/m/" but for the "m." and "mobile." subdomains [1].

[1] https://github.com/mozilla-mobile/android-components/blob/releases/105.0/components/browser/engine-gecko/src/main/java/mozilla/components/browser/engine/gecko/GeckoEngineSession.kt#L422-L442

While it wouldn't fix the example from the bug description it would be an improvement at least, I guess.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: