Closed Bug 1791347 Opened 8 days ago Closed 8 days ago

Display of macOS/LDAP contacts is broken

Categories

(Thunderbird :: Address Book, defect)

defect

Tracking

(thunderbird_esr102 affected)

RESOLVED FIXED
106 Branch
Tracking Status
thunderbird_esr102 --- affected

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Every selection of a contact from an LDAP or macOS address book logs the following error:

JavaScript error: chrome://messenger/content/addressbook/aboutAddressBook.js, line 3205: TypeError: can't access property "getAllValues", card.vCardProperties is null

This is the _screenNamesToIMPPs function which hasn't accounted for cards that do not support vCardProperties.

Target Milestone: --- → 106 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/01993715625a
Fix display of LDAP/macOS contacts. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 8 days ago
Resolution: --- → FIXED

102 is unaffected so far, this was caused by bug 1789990 which is not yet on 102.

You need to log in before you can comment on or make changes to this bug.