Closed Bug 1791642 Opened 4 months ago Closed 4 months ago

Users should not be able to enable force disabled calendars.

Categories

(Calendar :: Calendar Frontend, defect)

defect

Tracking

(thunderbird_esr102+ affected)

RESOLVED FIXED
107 Branch
Tracking Status
thunderbird_esr102 + affected

People

(Reporter: lasana, Assigned: lasana)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

When users create calendars using add-ons then remove the add-on (but not the calendar), the calendar manager creates an instance of the calDummyCalendar to act as the provider for the calendar. No warning or prompt is given to the user and the calendar shows up in the calendar list in a disabled state. The user can however, enable the calendar but attempting to write to it results in errors being thrown and the operation failing on the user silently.

It's seems like bad UX to pretend the calendars are still accessible without warning the user. There could potentially be other problems caused by this too as the dummy calendars are included in the list iterated in various places.

In this bug I propose removing calDummyCalendar and instead, informing the user that they have calendars without out a provider backend. Something along the lines of Services.prompt.alert.

IIRC what used to happen was the calendars would appear in the list but it wasn't possible to enable them (the force-disabled property). Not sure where or how that changed, but it's an alternative option.

I'm going a different route here then. After looking at the conversation and patches around the force-disabled property further I discovered there was already UI to indicate to the user the calendar is missing a provider and cannot be enabled. I still question the way this is handled and the need for the dummy calendar but I'm going to leave that up to the calendar UX review.

Assignee: nobody → lasana
Component: Internal Components → Calendar Frontend
Regressed by: 306495
No longer regressed by: 1652885
Summary: Get rid of calDummyCalendar → Users should not be able to enable force disabled calendars.
Status: NEW → ASSIGNED
Attachment #9296266 - Attachment description: Bug 1791642 - Always keep calendar properties dialog disabled when force-disabled set. r=#thunderbird-reviewers → Bug 1791642 - Restore hiding disable/enable checkbox when force-disabled property set. r=#thunderbird-reviewers
Target Milestone: --- → 107 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/af01fb4826a9
Restore hiding disable/enable checkbox when force-disabled property set. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.