Context menu no longer appears in thread or folder panes

VERIFIED FIXED in mozilla1.3alpha

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Christopher Aillon (sabbatical, not receiving bugmail), Assigned: Brian Ryner (not reading))

Tracking

({regression})

Trunk
mozilla1.3alpha
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Linux build 2002110822:

1. Load mailnews
2. Right click on any message.

Expected results:
Context menu appears

Actual results: nothing happens.

This worked as recently as 2002110710.
Keywords: regression
Whoops, I meant thread pane.
Summary: Context menu no longer appears in message pane → Context menu no longer appears in thread pane

Comment 2

16 years ago
I can confirm this with the latest nightly on Linux.

Comment 3

16 years ago
Raising severity to Major.
Severity: normal → major
wfm lnux trunk cvs 2002-11-08 ~11pdt, so it looks like 2002-11-08 11 / 22

Comment 5

16 years ago
I'm unable to get context menu in either thread pane or accounts sidebar
(right-click on a folder, for example)
Message pane context menu still works fine.
2002110921 under linux
accepting.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.3alpha
I'm able to reproduce this with an official build from ftp.mozilla.org

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021111

both folder pane and thread pane.

I'll see if any other trees are having context menu issues.
I just did a debug build, and it seems to be working there.

so the first two things that come to mind are:

1) a regression (that was recently fixed)
2) a packaging issue.
or 

3) something debug vs. opt.
I just pulled the latest build (2002111122) and it is still broken there.  This
rules out #1.
Could this be caused by bryner's checkin for bug 124990 maybe?
In my opt build, fillThreadPaneContextMenu() and fillFolderPaneContextMenu()
aren't getting called, but they are in my debug build.
I just did a local backout of the event re-ordering patch from bug 124990. 
After backing it out, context menus work again in mail...

Comment 15

16 years ago
*** Bug 179681 has been marked as a duplicate of this bug. ***
> I just did a debug build, and it seems to be working there.

I'm such a loser.

I do a debug build, and it only works because I do:

cd dist/bin
mozilla -mail

instead of 

cd dist/bin
./mozilla -mail

broken on debug and opt.  see what using win32 99% of the time does to you?

re-assign to bryner, as his patch for #124990 appears to have caused this.

(callion asked me to investigate, yet he ended up doing all the work.)
Assignee: sspitzer → bryner
Status: ASSIGNED → NEW

Comment 17

16 years ago
*** Bug 179791 has been marked as a duplicate of this bug. ***
Summary: Context menu no longer appears in thread pane → Context menu no longer appears in thread or folder panes
(Assignee)

Comment 18

16 years ago
Created attachment 106014 [details] [diff] [review]
fix for gtk and gtk2
(Assignee)

Comment 19

16 years ago
Created attachment 106016 [details] [diff] [review]
oops, this one actually has the gtk1 patch
Attachment #106014 - Attachment is obsolete: true

Comment 20

16 years ago
Comment on attachment 106016 [details] [diff] [review]
oops, this one actually has the gtk1 patch

r=varga, tested with linux gtk1 build
Attachment #106016 - Flags: review+
Attachment #106016 - Flags: superreview+
(Assignee)

Comment 21

16 years ago
checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 22

16 years ago
*** Bug 181161 has been marked as a duplicate of this bug. ***

Comment 23

16 years ago
OK using nov20 commercial trunk build: linux rh8, win98
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.