Closed Bug 1791759 Opened 1 year ago Closed 1 year ago

Implement CSS Containment content-visibility: auto

Categories

(Core :: Layout, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
109 Branch
Tracking Status
firefox109 --- fixed

People

(Reporter: mrobinson, Assigned: mrobinson)

References

(Blocks 2 open bugs)

Details

(Keywords: dev-doc-complete)

Attachments

(2 files)

This bug tracks implementing the auto value of the content-visibility property.

This change adds support for content-visibilty: auto as well as
showing and hiding content based on the relevancy of the content as
defined in the specification. Changes to relevancy are handled by
triggering updates in a set of content-visibility: auto frames stored
in PresShell at the appropriate time in the document lifecycle.

Some tests are updated. In the case of content-visibility-068.html a new
node is added in order to properly test focus() and blur() without only
having a single focusable element on the page.

Attachment #9299217 - Attachment description: WIP: Bug 1791759 - Add support for `content-visibility: auto` → Bug 1791759 - Add support for `content-visibility: auto` r=emilio
Pushed by mrobinson@igalia.com:
https://hg.mozilla.org/integration/autoland/rev/c428c3ad7725
Add support for `content-visibility: auto` r=emilio
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/37183 for changes under testing/web-platform/tests

Backed out changeset c428c3ad7725 (Bug 1791759) for causing wpt failures on auto-012.html.
Backout link
Push with failures <--> wpt29
Failure Log

Flags: needinfo?(mrobinson)
Upstream PR was closed without merging
Pushed by mrobinson@igalia.com:
https://hg.mozilla.org/integration/autoland/rev/c1e64e8e4665
Add support for `content-visibility: auto` r=emilio

I uploaded a new version of this change which fixed the failing test and landed it after confirming with emilio that it looked okay.

Flags: needinfo?(mrobinson)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 109 Branch
Upstream PR merged by moz-wptsync-bot
Keywords: dev-doc-needed
Depends on: 1804761

Docs worked can be tracked here https://github.com/mdn/content/issues/22736

Depends on: 1807251
Depends on: 1807253
Regressions: 1807965

Associated Pull Requests

mdn/browser-compat-data:

mdn/content:

releases

Attachment #9316594 - Attachment description: WIP: Bug 1791759 - remove unused ContentRelevancyReason::DescendantOfTopLayerElement → Bug 1791759 - remove unused ContentRelevancyReason::DescendantOfTopLayerElement
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/62c1b893b282
remove unused ContentRelevancyReason::DescendantOfTopLayerElement r=emilio

A patch has been attached on this bug, which was already closed. Filing a separate bug will ensure better tracking. If this was not by mistake and further action is needed, please alert the appropriate party. (Or: if the patch doesn't change behavior -- e.g. landing a test case, or fixing a typo -- then feel free to disregard this message)

Blocks: 1852199
Duplicate of this bug: 1852199
No longer blocks: 1852199
You need to log in before you can comment on or make changes to this bug.