When filing a new bug, the generated bugmail doesn't include Product/Component

RESOLVED FIXED in Bugzilla 2.18

Status

()

--
blocker
RESOLVED FIXED
16 years ago
6 years ago

People

(Reporter: justdave, Assigned: bbaetz)

Tracking

({regression})

2.17
Bugzilla 2.18
regression

Details

Attachments

(1 attachment, 1 obsolete attachment)

v2
656 bytes, patch
myk
: review+
myk
: review+
Details | Diff | Splinter Review
Date: Sat, 9 Nov 2002 02:17:25 -0800 (PST)
From: bugzilla-daemon@mozilla.org
To: justdave@netscape.com
Subject: [Bug 179174] New: Need to fix use of $| (for buffering)
X-Bugzilla-Reason: CC

http://bugzilla.mozilla.org/show_bug.cgi?id=179174

           Summary: Need to fix use of $| (for buffering)
           Version: 2.17
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: blocker
          Priority: --
        AssignedTo: bbaetz@student.usyd.edu.au
        ReportedBy: bbaetz@student.usyd.edu.au
         QAContact: matty@chariot.net.au
                CC: myk@mozilla.org


The pre-CGI.pm code did $| = 1.
[...]
(Assignee)

Comment 1

16 years ago
DIE, EVIL @::LOG_COLUMNS!!!!

Whats happening is that processmail is using log_columns, but product isn't in
there, only product_id.

Evil hack^W^WFix coming, so -> me
Assignee: preed → bbaetz
Keywords: regression
Target Milestone: --- → Bugzilla 2.18
(Assignee)

Comment 2

16 years ago
Created attachment 105671 [details] [diff] [review]
fix

We have to get rid of log_columsn well before custfields....

Anyway, try this.
Comment on attachment 105671 [details] [diff] [review]
fix

r= justdave
a= justdave
Attachment #105671 - Flags: review+
Comment on attachment 105671 [details] [diff] [review]
fix

>Index: processmail
>===================================================================
>RCS file: /cvsroot/mozilla/webtools/bugzilla/processmail,v
>retrieving revision 1.91
>diff -u -r1.91 processmail
>--- processmail	17 Oct 2002 04:31:53 -0000	1.91
>+++ processmail	9 Nov 2002 11:23:14 -0000
>@@ -108,6 +108,9 @@
>     foreach my $i (@::log_columns) {
>         $values{$i} = shift(@row);
>     }
>+    $values{product} = get_product_name($values{product_id});
>+    $values{component} = get_component_name($values{product_id},
>+                                            $values{component_id});
>     my ($start, $end) = (@row);
>     # $start and $end are considered safe because users can't touch them
>     trick_taint($start);

I love evil hacks that work, but this one doesn't.  Gotta do:

get_component_name($values{component_id});
Attachment #105671 - Flags: review-
(Assignee)

Comment 5

16 years ago
Created attachment 105672 [details] [diff] [review]
v2

Err, yeah, of course.

/me wnats function prototyping
Attachment #105671 - Attachment is obsolete: true
Attachment #105672 - Flags: review+
(Assignee)

Comment 6

16 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Summary: When filing a new bug, the generated bugmail doesn't include Product → When filing a new bug, the generated bugmail doesn't include Product/Component
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.