autocomplete popup too small (need resizable dropdown)

RESOLVED WONTFIX

Status

()

Firefox
Address Bar
--
enhancement
RESOLVED WONTFIX
16 years ago
9 years ago

People

(Reporter: hugo van woerkom, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021108 Phoenix/0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021108 Phoenix/0.4

When selecting URL autocomplete presents a window that is fixed and for userids
like "hugovanwoerkom" and "hugovanwoerkomqt" is useless because it only shows
"hugovanwoerk..."
Second it doesn't always work. Using the URL repeatedly gives mixed results.

Reproducible: Always

Steps to Reproduce:
1.Go to referenced URL
2.Type the character 'h'
3.Either shows nothing or "hugovanwoerk..."


Actual Results:  
As per details.

Expected Results:  
The prompt should always show up and the all entries should be completely shown.

Comment 1

16 years ago
Hugo, can you please try a recent nightly build of Mozilla and see if it
reproducable there too?
(Reporter)

Comment 2

16 years ago
Will do. Let u know.
(Reporter)

Comment 3

16 years ago
Installed
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-i686-pc-linux-gnu-sea.tar.gz
that's Mozilla 1.3a Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021110
It hangs in a loop on startup for root and another user, but that's another story.
Upon access of Yahoo! Mail several times and putting in userid etc. it never
prompts me for any userid.

Comment 4

16 years ago
For the first problem (too small window) I can confirm the too small widget for
the form autocomplete (see attachment), but I was not able to reproduce the
problem using a nightly build of Mozilla, as Mozilla didn't saved the data I
entered...
Nevertheless this bug is more an enhancement request rather than a "bug" and
might get fixed by the resizable popups mentioned in bug #78508, though I doubt
this bug will ever get fixed (not much traffic within the last year).

For the second problem reported with this bug (autocomplete sometimes doesn't
work) I suggest filing a seperate bug rather than to use one bug for two
different things.

So I will change the severity for the widget-problem to "enhancement" and if the
problem with the not working autocomplete-stuff still persists, a seperate bug
should be filed!
Severity: normal → enhancement

Comment 5

16 years ago
Created attachment 113487 [details]
a screenshot of an autocomplete popup which is too small, but not resizable
Joe: do we want to enable stretching the autocomplete box?  the URL autocomplete
bar might do weird things if we do.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

15 years ago
Taking QA. Sorry for the bugspam
QA Contact: asa → davidpjames

Updated

14 years ago
Flags: blocking1.0?
-ing... will take a tested resizable autocomplete popup patch ;-) 
Flags: blocking1.0? → blocking1.0-
Assignee: hewitt → nobody
Component: Location Bar and Autocomplete → Autocomplete
Depends on: 95401
Flags: blocking-aviary1.0-
OS: Linux → All
Product: Firefox → Toolkit
QA Contact: davidpjames → nobody
Hardware: PC → All
Summary: Autocomplete doesn't operate OR window too small (78508?) → autocomplete popup too small (need resizable dropdown)
Version: unspecified → Trunk

Updated

9 years ago
Component: Autocomplete → Location Bar and Autocomplete
Product: Toolkit → Firefox
QA Contact: nobody → location.bar

Updated

9 years ago
Whiteboard: wontfix?
For the location bar this is WONTFIX.  There's another bug about widening the form autocomplete if needed.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
Whiteboard: wontfix?
You need to log in before you can comment on or make changes to this bug.