Open Bug 1792286 Opened 2 months ago Updated 1 month ago

firefox slow to render initial page when first started

Categories

(Core :: Storage: IndexedDB, defect)

Firefox 105
defect

Tracking

()

UNCONFIRMED

People

(Reporter: aa_asics, Unassigned, NeedInfo)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:105.0) Gecko/20100101 Firefox/105.0

Steps to reproduce:

Clicked on a windows 10 icon containing "C:\Program Files\Mozilla Firefox\firefox.exe" -new-window https://www.google.com

Actual results:

Window opened quickly, then spun for a while before rendering

Expected results:

should have rendered quickly as it does when there is another open window.

dom.push.userAgentID 97142bbad26b48bcb1c586a59b6354d1

detailed reddit post : https://www.reddit.com/r/firefox/comments/xlo0wt/firefox_slow_to_render_initial_page_when_first/

This appears to be due to a network request spending an extraordinarily large amount of time waiting for the socket request. (Because of the privacy settings of this profile I can't tell what request that is, but I'm guessing it's the main page)

Moving this to Network. Hopefully they'll be able to give instructions for a more actionable profile.

Component: Performance → Networking

The network request is delayed by IndexedDB initialization (via uBlock Origin): https://share.firefox.dev/3TTAA75

Component: Networking → Storage: IndexedDB

Hi Jan, I assume this is related to bug 1671932 ?

Flags: needinfo?(jvarga)
You need to log in before you can comment on or make changes to this bug.