Closed Bug 1792441 Opened 2 months ago Closed 2 months ago

Firefox closes when restoring the previous session from the "Show me how" button after the Firefox View tab was focused

Categories

(Firefox :: Firefox View, defect)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
107 Branch
Tracking Status
firefox106 --- verified
firefox107 --- verified

People

(Reporter: Gabi, Assigned: niklas)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [fidefe-2022-mr1-firefox-view])

Attachments

(2 files)

Attached video restore.mp4

Found in

  • Firefox 106.0b4

Affected versions

  • Firefox Nightly 107.0a1
  • Firefox 106.0b4

Tested platforms

  • Affected platforms: Windows 10x64, macOS 10.12.6, Ubuntu 22
  • Unaffected platforms: -

Steps to reproduce

  1. Launch Firefox with a new profile
  2. Open a few tabs for history purposes
  3. Close Firefox
  4. Open Firefox with the same profile
  5. Focus the Firefox View tab
  6. Go to the other open tab to see the "restore previous session" message
  7. Click on "Show me how" button and restore the previous session

Expected result

  • Firefox closes when restoring the previous session from the "Show me how" button after the Firefox View tab was focused

Actual result

  • The previous session should be restored without any issues.

Regression range

  • Most likely not a regression since issue is reproducible with Nightly 105.0a1

Additional notes

  • See the attached screen recording
  • Issue is not reproducible if the Firefox View tab was not selected before
Whiteboard: [fidefe-2022-mr1-firefox-view]

Niklas, can you take a look at this?

Flags: needinfo?(nbaumgardner)
Assignee: nobody → nbaumgardner
Status: NEW → ASSIGNED
Flags: needinfo?(nbaumgardner)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c91bf964f30f
Keep window open when restoring with hidden tabs. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch

Comment on attachment 9296413 [details]
Bug 1792441 - Keep window open when restoring with hidden tabs. r=gijs!,dao!

Beta/Release Uplift Approval Request

  • User impact if declined: Windows closing willy-nilly when they shouldn't, manual session restore not working correctly
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 0
  • List of other uplifts needed: No
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Straightforward expansion of previous JS-only fix, has automated test
  • String changes made/needed: No
  • Is Android affected?: No
Attachment #9296413 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9296413 [details]
Bug 1792441 - Keep window open when restoring with hidden tabs. r=gijs!,dao!

Approved for 106.0b7, thanks.

Attachment #9296413 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Verified that the issue is fixed on Firefox 106.0b7 and 107.0a1. Tests were performed on macOS 13, Windows 11 and Ubuntu 22.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Perfherder has detected a talos performance improvement from either this or Bug 1792546. Do you believe this patch could have caused the following improvement?

== Change summary for alert #35617 (as of Tue, 04 Oct 2022 17:43:26 GMT) ==

Improvements:

Ratio Test Platform Options Absolute values (old vs new)
7% perf_reftest_singletons id-getter-2.html windows10-64-shippable-qr e10s fission stylo webrender 675.96 -> 629.55

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=35617

Flags: needinfo?(nbaumgardner)

It doesn't seem likely that this patch caused the performance improvement

Flags: needinfo?(nbaumgardner)
You need to log in before you can comment on or make changes to this bug.