Closed Bug 1792451 Opened 3 months ago Closed 2 months ago

New error on TB 102.3, POP3: "The account X is being processed. Please wait until processing is complete to get messages." (with slow or not responsive server)

Categories

(MailNews Core :: Networking: POP, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr102 fixed, thunderbird106 fixed)

RESOLVED FIXED
107 Branch
Tracking Status
thunderbird_esr102 --- fixed
thunderbird106 --- fixed

People

(Reporter: fqgouvea, Assigned: rnons)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:105.0) Gecko/20100101 Firefox/105.0

Steps to reproduce:

This seems to be new with Thunderbird 102.3.0 (32-bit), which was installed a few days ago. Running on Windows 10 Enterprise. Using POP3. Mail server is Gmail.

Open Thunderbird, mail gets checked automatically.
Wait a bit.
Click on "check messages".

Actual results:

Pop-up message:
The account X is being processed. Please wait until processing is complete to get messages.

Nothing gets downloaded until I restart the program.

Expected results:

Messages should have been checked.

The error seems to happen when the server is slow or stops responding. Perhaps what is happening is that instead of timing out, the program keeps trying to check for new email, with the result that the account "is being processed" forever.

(In reply to Fernando Gouvea from comment #1)

The error seems to happen when the server is slow or stops responding. Perhaps what is happening is that instead of timing out, the program keeps trying to check for new email, with the result that the account "is being processed" forever.

Ping, any insights?

Severity: -- → S3
Component: Untriaged → Networking: POP
Flags: needinfo?(remotenonsense)
Product: Thunderbird → MailNews Core
Summary: New error: The account X is being processed. Please wait until processing is complete to get messages. → New error on TB 102.3, POP3: "The account X is being processed. Please wait until processing is complete to get messages." (with slow or not responsive server)
Assignee: nobody → remotenonsense
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Thanks for reporting, I'm not totally sure my patch can fix your problem, but worth a try.

Flags: needinfo?(remotenonsense)
Regressed by: pop3-js

Fernando, can you attach a pop3 protocol log? https://wiki.mozilla.org/MailNews:Logging

Target Milestone: --- → 107 Branch

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/144b74e92a20
Set socket timeout in Pop3Client to release folder lock. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Comment on attachment 9296418 [details]
Bug 1792451 - Set socket timeout in Pop3Client to release folder lock. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): pop3-js
User impact if declined: If Pop3Client is waiting for a unresponsive server, the folder maybe locked for a long time.
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): no risk

Attachment #9296418 - Flags: approval-comm-esr102?
Attachment #9296418 - Flags: approval-comm-beta?

Comment on attachment 9296418 [details]
Bug 1792451 - Set socket timeout in Pop3Client to release folder lock. r=mkmelin

[Triage Comment]
Approved for beta

[Triage Comment]
approved for esr102

Attachment #9296418 - Flags: approval-comm-esr102?
Attachment #9296418 - Flags: approval-comm-esr102+
Attachment #9296418 - Flags: approval-comm-beta?
Attachment #9296418 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.