latest CVS mozilla doesn't build with --enable-xft on FreeBSD

VERIFIED DUPLICATE of bug 175523

Status

SeaMonkey
Build Config
VERIFIED DUPLICATE of bug 175523
16 years ago
14 years ago

People

(Reporter: Tomas Pluskal, Assigned: blizzard)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Opera/6.1 (FreeBSD 4.6-RELEASE i386; U)  [en]
Build Identifier: latest CVS

I've been trying to compile mozilla from source (todays CVS) with Xft enabled, and it ended up with this message:

c++ -o nsGfxFactoryGTK.o -c -DNATIVE_THEME_SUPPORT -DOSTYPE=\"FreeBSD4\" -DOSARCH=\"FreeBSD\" -DOJI 
-DUSE_POSTSCRIPT -DUSE_XPRINT -DUSE_MOZILLA_TYPES -DMOZ_ENABLE_FREETYPE2 -I./. -I./.. -I./../shared 
-I./../x11shared  -I../../../dist/include/xpcom -I../../../dist/include/string -I../../../dist/inclu
de/widget -I../../../dist/include/view -I../../../dist/include/util -I../../../dist/include/pref -I.
./../../dist/include/uconv -I../../../dist/include/unicharutil -I../../../dist/include/locale -I../.
./../dist/include/necko -I../../../dist/include/content -I../../../dist/include/layout -I../../../di
st/include/imglib2 -I../../../dist/include/gfx -I../../../dist/include -I/usr/src/moz-cvs/mozilla/di
st/include/nspr      -I/usr/local/include/freetype2 -I/usr/local/include -I/usr/X11R6/include   -fPI
C  -I/usr/X11R6/include  -I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer
-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -pedantic -Wno-long-long -pi
pe  -DNDEBUG -DTRIMMED -I/usr/X11R6/include -I/usr/local/include/freetype2 -I/usr/local/include   -I
/usr/X11R6/include/gtk12 -I/usr/local/include/glib12 -I/usr/local/include -I/usr/X11R6/include   -I/
usr/X11R6/include  -I/usr/X11R6/include -DMOZILLA_CLIENT -include ../../../mozilla-config.h -Wp,-MD,
.deps/nsGfxFactoryGTK.pp nsGfxFactoryGTK.cpp
In file included from /usr/X11R6/include/gtk12/gdk/gdktypes.h:33,
                 from /usr/X11R6/include/gtk12/gdk/gdk.h:31,
                 from /usr/X11R6/include/gtk12/gtk/gtk.h:31,
                 from nsDrawingSurfaceGTK.h:48,
                 from nsRenderingContextGTK.h:55,
                 from nsGfxFactoryGTK.cpp:47:
/usr/local/include/glib12/glib.h:1314: warning: ANSI C does not allow macro with variable arguments
/usr/local/include/glib12/glib.h:1317: warning: ANSI C does not allow macro with variable arguments
/usr/local/include/glib12/glib.h:1320: warning: ANSI C does not allow macro with variable arguments
/usr/local/include/glib12/glib.h:1323: warning: ANSI C does not allow macro with variable arguments
In file included from nsGfxFactoryGTK.cpp:65:
nsFontMetricsXft.h:248: syntax error before `*'
gmake[4]: *** [nsGfxFactoryGTK.o] Error 1
gmake[4]: Leaving directory `/usr/src/moz-cvs/mozilla/gfx/src/gtk'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory `/usr/src/moz-cvs/mozilla/gfx/src'
gmake[2]: *** [libs] Error 2
gmake[2]: Leaving directory `/usr/src/moz-cvs/mozilla/gfx'
gmake[1]: *** [tier_9] Error 2
gmake[1]: Leaving directory `/usr/src/moz-cvs/mozilla'
gmake: *** [default] Error 2

The problem is (I believe) in 
mozilla/gfx/src/gtk/nsFontMetricsXft.h

When I change
#include <X11/Xft/Xft.h>
to
#include <X11/Xft/Xft2.h>
It compiles OK (it segfaults when trying to run, but that might be another issue).

I have installed my Xft from ports (as usual on FreeBSD), it works fine in other apps.

My /usr/X11/include/X11/Xft directory contains:
-r--r--r--  1 root  wheel   5358  9 lis 14:41 XftCompat.h
-r--r--r--  1 root  wheel   4217 23 úno  2002 XftFreetype.h
-r--r--r--  1 root  wheel  11563  9 lis 14:41 Xft2.h
-r--r--r--  1 root  wheel  11167 23 úno  2002 Xft.h




Reproducible: Always

Steps to Reproduce:
--enable-xft requires xft 2.  
-> blizzard
Assignee: seawood → blizzard
This is a bug in the BSD headers, pure and simple.  Contact your OS maintainer.

*** This bug has been marked as a duplicate of 175523 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.