sonypictures.com - Selecting "Newsletter Sign Up" at PYRAMID causes NPSWF32 (Shockwave Flash) to crash

VERIFIED WORKSFORME

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
VERIFIED WORKSFORME
15 years ago
8 years ago

People

(Reporter: Matt Seitz, Assigned: rubydoo123)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; AT&T WNS5.0; AT&T WNS5.2; AT&T CSM6.0; T312461)
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021108

When I select the "Newsletter Sign Up" icon, Windows reports an access 
violation.

Reproducible: Always

Steps to Reproduce:
1.  Go to http://www.sonypictures.com/tv/shows/pyramid/
2.  Close the pop-up window promoting Olympics week
3.  Select the icon labelled "Newsletter Sign Up" at the right side of the 
screen, directly under the giant PYRAMID logo.

Actual Results:  
Windows reports that Mozilla has executed an illegal instruction.

Expected Results:  
Mozilla should display the newsletter sign up form.

Crash occurs in kernel32.dll called from NPSWF32! 021e884b().  Problem does not 
occur with Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021016.
(Reporter)

Comment 1

15 years ago
Created attachment 105710 [details]
Stack trace and register dump
(Reporter)

Comment 2

15 years ago
Info on NPSWF32:    

File name: NPSWF32.dll
Shockwave Flash 6.0 r47
Summary: sonypictures.com - Selecting "Newsletter Sign Up" at PYRAMID site crashes MOZILLA → sonypictures.com - Selecting "Newsletter Sign Up" at PYRAMID causes NPSWF32 (Shockwave Flash) to crash

Comment 3

15 years ago
wfm using Phoenix 20021108 on Win2k + Flash 6.0.60.65.
JavaScript console shows a neverending warning though:

Error: nav_DoFSCommand is not defined
Source File: javascript: function jsScriptObject(obj) { this.wrappedJSObject =
obj; } jsScriptObject.prototype = { evaluate : function(expression) { return new
jsScriptObject(eval(expression)); } }; var plugin = document.embeds['nav'];
plugin.SetWindow(new jsScriptObject(window),1005294507);
Line: 1
Assignee: asa → beppe
Component: Browser-General → Plug-ins
Keywords: crash
QA Contact: asa → shrir

Comment 4

15 years ago
Confirmed on Linux 2002110822 with Flash Player 6.0 r60 (beta). Clicking on
'Sign up' made Mozilla close.
wfm with win2k build 20021106.. and flash 6.0 r47

Comment 6

15 years ago
Crash confirmed 2002110808/Win98, talkback ID TB13730824K
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: stackwanted
(Assignee)

Comment 7

15 years ago
WFM on winXP with trunk build from 20021108 and Shockwave Flash 6.0 r47

Updated

15 years ago
Whiteboard: TB13730824K
(Assignee)

Comment 8

15 years ago
Created attachment 106865 [details]
talkback report

attaching talkback from comment #6

Comment 9

15 years ago
Do you also crash with Flash 6.0r60 ?
http://www.macromedia.com/software/flashplayer/special/beta/
Keywords: stackwanted
Whiteboard: TB13730824K
(Assignee)

Updated

15 years ago
Whiteboard: [awaiting response from reporter]
(Reporter)

Comment 10

15 years ago
I cannot reproduce the problem using:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021120    
File name: NPSWF32.dll
Shockwave Flash 6.0 r61
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

15 years ago
Whiteboard: [awaiting response from reporter]
(Assignee)

Comment 11

15 years ago
yes, if the user uses the more current version it works fine.
Status: RESOLVED → VERIFIED

Comment 12

15 years ago
I always can reproduce this bug on Linux 2002112305, even with Flash 6.0 r61.
All the previous versions did also crash.
Should the bug be reopened?

Comment 13

15 years ago
Daniel, does http://poppy.macromedia.com/flashplayer/version/ mention Flash 5 or 6 ?

Comment 14

15 years ago
It says LNX 6,0,61,0  Release Player
The same as about:plugins,  Shockwave Flash 6.0 r61

Also some people could crash the page with other versions

Comment 15

15 years ago
Daniel, can you post Talkback ID for this crash w/ Flash 6 ?
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 16

15 years ago
As I use nightly build on Linux, it doesn't have Talkback. I installed 1.2
instead, but it seems it has some problems (bug 182550); anyway I start
"Netscape Feedback Agent", but it doesn't seem to catch the browser crash. I've
never used it before, and I don't find any "Talkback howto"... :-( I'll continue
trying. Sorry for the inconveniences...

Comment 17

15 years ago
daniel ,do u have the flashplayer.xpt file in ur plugins folder? Thx ! Btw, this 
wfm just fine with 1126 trunk on XP.

Comment 18

15 years ago
Yes, I missed that file (I thought only the .so was needed), and now the problem
is gone! :-) Thanks to everyone.
But, why is that file so important? I hope it's not a Mozilla bug. Should I file
another bug? (something like "Flash eventually crashes if there's not
flashplayer.xpt").
This one gets WFM'ed.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 19

15 years ago
v
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: shrir → adobe-flash
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.