Closed Bug 1792748 Opened 4 months ago Closed 4 months ago

Sidebar width is no longer restored after restart

Categories

(Firefox :: Theme, defect)

defect

Tracking

()

VERIFIED FIXED
107 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox105 --- unaffected
firefox106 --- unaffected
firefox107 --- verified

People

(Reporter: jryans, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR

  1. Start from a clean profile (or at least a profile with only one window)
  • You may need to enable "Open previous windows and tabs", unsure...
  1. Open a sidebar, such as bookmarks (View -> Sidebars -> Bookmarks)
  2. Change the sidebar width (to some non-default value you'll recognise) by dragging the splitter
  3. Restart Firefox

ER

The custom sidebar width should be restored after Firefox restart when the window opens.

AR

The default sidebar width is used instead.

Notes

The correct custom width is being loaded and set as a width attribute on sidebar-box, but this is perhaps being ignored with the modern flexbox mode...?

Emilio, perhaps you have some idea what's going on since you've worked on the switch to modern flexbox here...?

Flags: needinfo?(emilio)

Set release status flags based on info from the regressing bug 1789168

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7ec263b6ba8c
Persist sidebar style attribute rather than width attribute. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch

I have verified that the core fix for new sidebar widths is working, but the migration code has a small error. I've attached a fix over in bug 1793366.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Reproduced the issue in Nightly 107.0a1 (2022-09-28) using Windows 10.
Verified - Fixed in Beta 107.0b3 and the latest Nightly 108.0a1 (2022-10-21) on Windows 10, macOS 12 and Ubuntu 20.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.