Sheet being displayed blocks other windows from loading pages

RESOLVED FIXED in Camino1.5

Status

Camino Graveyard
General
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: Avi Drissman, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino1.5
PowerPC
Mac OS X

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021029 Chimera/0.5+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021029 Chimera/0.5+

If a window has a sheet attached to it, no other pages will load.

Reproducible: Always

Steps to Reproduce:
1. Open two windows.
2. In window A, in the location bar, type "javascript:alert("blah");" and press
return. That window will get a sheet. Leave the sheet.
3. In window B, type in any site's address in the location bar. Press return.

Actual Results:  
Watch as window B is stuck at "Loading...". Wait forever if you want; it gets
nowhere. As soon as you close the sheet on window A, window B loads.

Expected Results:  
Window B's loading shouldn't be affected by window A's sheet.

Comment 1

15 years ago
Confirmed using Chimera/2002110804 on 10.1.5. It WorksForMe using
FizzillaCFM/2002110808.

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
Yeah, this is bad.
Assignee: saari → sfraser
Target Milestone: --- → Chimera1.1

Comment 3

14 years ago
I can reproduce this bug using the 200311 NB's.

Comment 4

14 years ago
Confirming comment #3

Comment 5

14 years ago
reassigning sfraser bugs to pinkerton
Assignee: sfraser → pinkerton
(Assignee)

Comment 6

14 years ago
btw, i spoke with conrad, that's how the nsIPrompt methods work by definition.
there is only 1 ui thread in gecko and any gecko prompt from nsIPrompt will
block loading on all other gecko instances.

take it up with the gecko guys if you want this to change, it's not anything we
can solve in camino. works as designed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 7

14 years ago
Fair, I understand that. But then, why does it work in Firefox? It has a sheet
too for Javascript alerts.

Updated

13 years ago
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 8

13 years ago
This works for me. I can load pages in window 2 while window 1 has a JS alert
showing.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.