Closed Bug 17931 Opened 20 years ago Closed 20 years ago

Use addr picker for two addressees, can't send message...

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: laurel, Assigned: hangas)

Details

If I use the address picker to address a message to more than one addressee
line, I can't send the message.  If I don't use the address picker to addess a
similar message, I can send it.

1.  Launch messenger. Login to mail account.  (I tried various accounts: POP,
IMAP, using HTML or plaintext compose window).
2.  Make sure there are a couple valid address cards in your address book.
3.  From messenger window, click New Msg.
4.  In the compose window, click Address, which brings up the address picker.
5.  In the address picker, select an address card then click To: and repeat for
another addressee. (I made sure these were valid email addresses that I chose.)
Click OK in the address picker.
    You are returned to the compose window with the two TO: addressees filled
in.
6.  Type a subject and body to the message and Click Send.
    Result:  Nothing happens. Message is not sent.
7.  Close the compose window.
8.  Compose another new message addressed to the same recipients, only do not
use the address picker. Send the message.
    Result:  message sends.

Note:  If you use the address picker for only one recipient line, the message
will send.

Actual result:  can't use the address picker to address more than one recipient
line. If you do, the message won't send.

Expected result:  should be able to use the address picker for multiple
recipient lines and still be able to send message.

Found using 1999-11-03-13m11 commercial build NT 4.0
QA Contact: lchiang → esther
Note:  It doesn't matter what that second addressee line header (To:, Cc:, Bcc:,
etc.) is, it simply won't send if the address picker is used to select two
address lines.
Status: NEW → ASSIGNED
Target Milestone: M12
Hardware: PC → All
fyi
Problem also occurs on MacOS commercial seamonkey 1999-11-04-08-m11.  I was
testing under POP with a single server profile.
OS: Windows NT → All
Problems still exist on 11-09-11-M11 Linux platform.
Change the OS to all.
release noted for M11.
*** Bug 18642 has been marked as a duplicate of this bug. ***
In OnFolderLoader
SendMessage from XUL
Linux Redhat 6.0 (1999-11-15-20 M11)
I used the latest build to re-test using address picker for two addresses and
send. I got the exception error when clicking on Send

GenericSendMessage from XUL
Identity = [nsIMsgIdentity: id4]
JavaScript Error: uncaught exception: [Exception... "Security error"  code:
"1000" nsresult: "0x805303e8 (NS_ERROR_DOM_SECURITY_ERR)"  location:
"chrome://messengercompose/content/addressingWidgetOverlay.js Line: 57"]
Mass move to M13.
Using M12 builds 1999121409 on win98, 1999121411 on linux and 1999121408 on Mac,
this is  working.   I used my IMAP account and the Select Addresses dialog with
3 names.  I added those names giving each a To: and all were sent and received.
This can be resolved as worksforme.   Duplicate bug 18642 is also working now
and has been verified, it was a dup of 18642 which was also verified.
Actually it was a dup of 19373 not a dup of itself.
Linux Redhat 6.0 (1999-12-14-11 M12)
This problem is fixed using the Linux build.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Linux Redhat 6.0 (1999-12-16-08 M12)
Win_nt 4.0 (1999-12-16-08 M12)
Mac (1999-12-16-15 M12)
Using the Address Picker, I send to 3 receipients using the To, Cc, and Bcc
fields, all 3 receipients receive the message.
This bug should be marked worksforme.
Status: RESOLVED → VERIFIED
This problem is fixed.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.