Right-click to paste when location bar already has focus and URL is not selected causes entire URL to be re-selected.

VERIFIED DUPLICATE of bug 96446

Status

SeaMonkey
Location Bar
--
minor
VERIFIED DUPLICATE of bug 96446
15 years ago
9 years ago

People

(Reporter: James Wagoner, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2b) Gecko/20021016

I wanted to paste a partial URL to the end of the URL in the location bar.

Reproducible: Always

Steps to Reproduce:
1. Copy text to paste to the end of the URL in the location bar.
2. Left-click the location bar to get focus (entire URL should be automatically
selected.
3. Left-click again at the end of the URL to place the insertion cursor at the
end of the URL (URL is de-selected, insertion cursor starts flashing after the
last character in the URL).
4. Right-click to bring up the Edit context menu for a text field/location bar
(Undo, Cut, Copy, Paste, Delete, Select All).

Actual Results:  
Mozilla re-selects the entire URL when it posts the Edit context menu for the
text field.

Expected Results:  
Mozilla should have left the URL un-selected so that I could paste to the end of
the URL.

I know that different platforms have different default behaviors for text
selection (e.g., Win32 vs. X), and that this issue may be as a result of trying
to be as general as possible. However, I think that this problem is important
enough to put out for general comment.

Selecting a text field, then specifically placing the insertion point to a
specific place in the URL (even if that place is at the end of the URL) should
be supported on every platform.

In fact I just tested putting the insertion cursor in the middle of the URL and
right-clicking to post the Edit context menu. It also re-selects the entire URL.

Note that Ctrl+V allows me to paste at the insertion point without re-selecting
the entire URL. As such, a work-around does exists, but I don't think the
current behavior exhibits standard User Interface behavior for a text field. If
I want to insert, then I want to insert at the exact location that I placed the
insertion point.
(Reporter)

Comment 1

15 years ago
Additional comment: This is similar to bug 168770, however, I think that that
particular bug is the opposite of this problem. Bug 168770 wants the entire URL
to be selected when pasting to the location bar; however, I think that the
pasting operation is done via the Edit context menu when the location bar does
NOT have focus.
(Reporter)

Comment 2

15 years ago
Nope, I was wrong about bug 168770. The problem described there is pasting into
the location bar when the location bar is "the currently selected widget".

The important difference between this bug and that bug is the platform (NT vs.
Linux).

Comment 3

15 years ago
worksforme; Windows XP Professional, Mozilla 1.2b 2002110808
This has been fixed for two weeks or so now (not in 1.2b, though).

*** This bug has been marked as a duplicate of 96446 ***

*** This bug has been marked as a duplicate of 96446 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
v.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.