onunload popups misattributed in "blocked popups" dialog

VERIFIED FIXED in Firebird0.7

Status

()

Firefox
General
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: Jesse Ruderman, Assigned: David Hyatt)

Tracking

unspecified
Firebird0.7
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
1. Visit a page with an onunload popup.
2. Press Alt+Home.

Result: A blocked-popup icon appears in the status bar.
Expected: The icon probably shouldn't appear.  It usually only appears while
you're viewing a site from which a popup was blocked.

3. Click the blocked-popup icon.

Result: My home page is listed as having tried to open a popup.
Expected: The page that tried to open a popup should be blamed, not my home page.
(Reporter)

Comment 1

16 years ago
Created attachment 105742 [details]
example of a page with an onunload popup

Comment 2

16 years ago
This is actually intentional, if a little confusing.  Talk to hyatt if you feel
strongly about it.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

16 years ago
I can understand how showing the icon while my home page is shown could be
intentional, but I find it hard to believe that showing my home page URL in the
blocked-popups dialog is intentional.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 4

16 years ago
Oh, my bad, you're right.  I thought this was just about the icon showing up.

Comment 5

16 years ago
-> hyatt
Assignee: blaker → hyatt
Status: REOPENED → NEW
Target Milestone: --- → Phoenix0.5

Comment 6

16 years ago
Mitch/jst, I don't have a debug build at the moment, but I'm guessing mDocument
must be the new document by the time we reach
http://lxr.mozilla.org/mozilla/source/dom/src/base/nsGlobalWindow.cpp#2900.
Target Milestone: Phoenix0.5 → Phoenix0.6
I bet danm knows what this is.

/be
(Reporter)

Comment 8

16 years ago
*** Bug 185223 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Target Milestone: Phoenix0.6 → Phoenix0.8
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
Target Milestone: Firebird0.8 → Firebird0.7
(Assignee)

Comment 9

15 years ago
Fixed.  This was actually a neat obscure bug.  The liveness of the location property was 
causing me to always use the current page.  My intent was obviously to use the location 
property's value at the time I got the popupblocked event.

Thanks for the test case.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → FIXED
Verified using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b)
Gecko/20030817 Mozilla Firebird/0.6.1+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.